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This document is copyrighted with all rights reserved. Under the copyright
laws, this document may not be copied in whole or in part or reproduced in
any other media without the express written permission of Coherent, Inc.
Permitted copies must carry the same proprietary and copyright notices as
were affixed to the original. This exception does not allow copies to be
made for others, whether or not sold, but all the material purchased may
be sold, given, or loaned to another person. Under the law, copying
includes translation into another language.

Coherent, the Coherent Logo, and BeamMaster are trademarks or
registered trademarks of Coherent, Inc. All other trademarks or registered
trademarks are the property of their respective owners.

Patents referenced in this user manual were active as of the printing date
of the manual (see last page for date). The patents referenced herein may
have expired. You are advised to check to see if the patents are still active:
http://portal.uspto.gov/external/portal/pair.

Every effort has been made to ensure that the data given in this document
is accurate. The information, figures, tables, specifications and schematics
contained herein are subject to change without notice. Coherent makes no
warranty or representation, either expressed or implied with respect to this
document. In no event will Coherent be liable for any direct, indirect,
special, incidental or consequential damages resulting from any defects in
its documentation.

Technical Support
In the US:
Should you experience any difficulties with your laser or need any
technical information, please visit our website: www.Coherent.com.
Additional support can be obtained by contacting our Technical Support
Hotline at 1.800.367.7890 (1.408.764.4557 outside the U.S.), or e-mail
Product.Support@Coherent.com. Telephone coverage is available around
the clock (except U.S. holidays and company shutdowns).

If you call outside our office hours, your call will be taken by our answering
system and will be returned when the office reopens.

If there are technical difficulties with your laser that cannot be resolved by
support mechanisms outlined above, e-mail, or telephone Coherent
Technical Support with a description of the problem and the corrective
steps attempted. When communicating with our Technical Support
Department via the web or telephone, the Support Engineer responding to
your request will require the model and Laser Head serial number of your
laser system.

Outside the US:
If you are located outside the U.S., visit our website for technical
assistance or contact our local service representative. Representative
phone numbers and addresses can be found on the Coherent website:
www.Coherent.com.

Coherent provides telephone and web technical assistance as a service to
its customers and assumes no liability thereby for any injury or damage
that may occur contemporaneous with such services. These support
services do not affect, under any circumstances, the terms of any warranty
agreement between Coherent and the buyer. Operation of any Coherent
laser with any of its interlocks defeated is always at the operator's own risk
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Preface
Preface This manual contains user information for the BeamMaster™-USB
Beam Diagnostics Measurement System.

U.S. Export 
Control Laws 
Compliance

It is the policy of Coherent to comply strictly with U.S. export
control laws.

Export and re-export of lasers manufactured by Coherent are subject
to U.S. Export Administration Regulations, which are administered
by the Commerce Department. In addition, shipments of certain
components are regulated by the State Department under the Inter-
national Traffic in Arms Regulations.

The applicable restrictions vary depending on the specific product
involved and its destination. In some cases, U.S. law requires that
U.S. Government approval be obtained prior to resale, export or
re-export of certain articles. When there is uncertainty about the
obligations imposed by U.S. law, clarification should be obtained
from Coherent or an appropriate U.S. Government agency.

Publication 
Updates

To view information that may have been added or changed since this
publication went to print, connect to www.Coherent.com.

Signal Words 
and Symbols in 
this Manual

This documentation may contain sections in which particular
hazards are defined or special attention is drawn to particular condi-
tions. These sections are indicated with signal words in accordance
with ANSI Z-535.6 and safety symbols (pictorial hazard alerts) in
accordance with ANSI Z-535.3 and ISO 7010.

Signal Words Four signal words are used in this documentation: DANGER,
WARNING, CAUTION and NOTICE.

The signal words DANGER, WARNING and CAUTION desig-
nate the degree or level of hazard when there is the risk of injury:

DANGER!
Indicates a hazardous situation that, if not avoided, will result in
death or serious injury. This signal word is to be limited to the
most extreme situations.
ix
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WARNING!
Indicates a hazardous situation that, if not avoided, could result
in death or serious injury.

CAUTION!
Indicates a hazardous situation that, if not avoided, could result
in minor or moderate injury.

The signal word “NOTICE” is used when there is the risk of prop-
erty damage:

NOTICE!
Indicates information considered important, but not hazard-
related.

Messages relating to hazards that could result in both personal injury
and property damage are considered safety messages and not prop-
erty damage messages.

Symbols The signal words DANGER, WARNING, and CAUTION are
always emphasized with a safety symbol that indicates a special
hazard, regardless of the hazard level:

This symbol is intended to alert the operator to the presence of
important operating and maintenance instructions.

This symbol is intended to alert the operator to the danger of
exposure to hazardous visible and invisible laser radiation.

This symbol is intended to alert the operator to the presence of
dangerous voltages within the product enclosure that may be of
sufficient magnitude to constitute a risk of electric shock.
 x
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This symbol is intended to alert the operator to the danger of
Electro-Static Discharge (ESD) susceptibility.

This symbol is intended to alert the operator to the danger of
crushing injury.

This symbol is intended to alert the operator to the danger of a
lifting hazard.
xi
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Introduction
SECTION ONE: INTRODUCTION

In this section:

• System contents (this page)

• Theory of operation (p. 1-3)

• BeamMaster-USB and beam diagnostics (p. 1-5)

The BeamMaster-USB is a beam diagnostics measurement system
for real-time measurement and display of CW lasers, fiber-optic, and
laser diode beam profiles. The BeamMaster-USB is designed to
provide maximum flexibility, speed, and user-friendliness for a
variety of beam measurements. Measurements include: beam width,
shape, position, power, and intensity profiles. Some of the applica-
tions include: beam alignment, on-line monitoring, gaussian fit anal-
ysis, beam position measurement, laser beam optimization, and
quality control.

The BeamMaster-USB external box and software can be integrated
into a variety of compatible PC computer platforms running under a
Windows XP, Windows Vista, or Windows 7 operating system. The
BeamMaster-USB system will meet a wide range of automated laser
analysis requirements in the laboratory, factory, and field.

System 
Contents

A basic BeamMaster-USB system includes:

Detector Head

• BM-3 (InGaAs)—a three knife-edge head for the 800 to 1800
nm wavelength range.

• BM-3 (Silicon-UV)—a three knife-edge head for the 190 to
1100 nm wavelength range.

• BM-7 (InGaAs)—a seven knife-edge head for the 800 to 1800
nm wavelength range.

• BM-7 (Silicon-UV)—a seven knife-edge head for the 190 to
1100 nm wavelength range.

USB External Box

This device is used for connecting the various detector heads to the
computer via a USB 2.0 port.
1 - 1
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Installation CD

The CD includes:

• BeamMaster-USB software

• User manual (in PDF format)

• Readme.txt file

• Required support files

Printed Manual

Filter Kit

The BM-7 and BM-3 Silicon heads come with two NG neutral
density filters. The NG4 & NG9 filters are provided to extend the
power range of the head from 5 mW to 1W. The NG4 filter comes
pre-installed and provides 10% transmission at 633 nm. The NG9 is
in a protective filter case and provides 0.5% transmission at 633 nm.
The filter kit also includes a hex wrench that can be used for swap-
ping the filters, a filter blank for 100% transmission, and filter trans-
mission data.

Mounting Post

The mounting post is 105 mm long and has an 8-32 thread. The post
is used for mounting the detector head.

Declaration of Compliance to CE Mark

This system can be ordered pre-installed in a variety of computer
configurations
1 - 2



Introduction
Theory of 
Operation

The BeamMaster-USB measures beam intensity profiles, widths,
position, power, and the basic beam shape of CW lasers. The
detector head utilizes multiple knife-edges to scan across the beam
and capture the intensity distribution of the laser.

A simplification of a BeamMaster-USB detector head is shown
below.

The rotating drum contains multiple knife-edge apertures (only one
is shown in this diagram). As an aperture passes between the laser
beam and the stationary power sensor, there is a period where the
entire beam is allowed to reach the sensor. At this point, the Beam-
Master-USB can measure the total power of the beam. As the aper-
ture is scanned across the beam, the knife-edge blocks off an increas-
ingly larger portion of the beam power. The power sensor measures
this change in power versus knife-edge position, creating a power
versus position plot, as shown below.

The analog power reading is digitized with a high speed A/D
(Analog-to-Digital) converter. At the same time, the exact position
of the knife-edge is monitored so that beam width information can
be determined. The beam profile for each knife-edge is then
obtained in software by taking the derivative of the measured power
curve. The beam profile is perpendicular to the knife-edge and each
1 - 3



BeamMaster-USB User Manual
point of the profile is the sum of all intensities along the axis of the
knife-edge at that knife- edge position. The digitized beam profiles
are then stored in memory.

The BeamMaster-USB obtains profiles from multiple knife-edges at
different orientations and has the ability to use this information to
create 2D and 3D plots of the beam. The mathematical reconstruc-
tion process is known as “Reconstructive Tomography.” The same
type of process is used by X-ray systems to create X-ray images. A
larger number of knife-edges will create better detail on
non-gaussian beams. For a beam distribution that is significantly
non-gaussian, the standard seven knife-edge system can reconstruct
a plot that closely matches the real beam.

There are two primary knife-edges used for the main profile display.
These knife-edges generate profile—referred to as W and V—that
are set perpendicular to each other and are oriented at 45 degrees in
relation to the base of the head. These profiles are used to provide
beam width, position, and gaussian fit analysis. The other
knife-edges are used for reconstructive tomography.

To increase the usable power range of the Silicon heads to 1W, the
NG4 (~ 10% transmission) and NG9 (~ 0.5% transmission), filters
can be inserted between the knife-edge and the sensor. This location
will prevent the attenuation from distorting the beam, since it is
behind the scanning plane.
1 - 4
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The data is combined with user-selected graphics and calculated
analysis results for display in a user-controlled window. A wide
variety of system functions also provide the ability to print informa-
tion, perform pass/fail testing, control capture rates, and log data.

BeamMaster-USB 
and Beam 
Diagnostics

Two general types of instruments measure laser beam intensity. The
following paragraphs explain the strengths and weaknesses of both
measurement techniques. The BeamMaster-USB bridges the gap
between the two techniques.

CCD Array 
Camera 
Diagnostics

Camera-based diagnostics use an array of sensor pixels to measure
simultaneously the intensity over the face of the entire laser beam.
This allows them to capture data from pulsed lasers and display the
data in 2D contour plots and 3D views. The pixels are of finite size
(6 to 12 µm) and the smallest measurable beam size is typically 40
times larger than the pixel. CCD camera-based diagnostics are very
sensitive and require high optical density laser grade filters to
prevent saturation and beam distortion. In some cases, this is not
desirable or practical.

Scanning Aperture 
Diagnostics

Scanning Aperture Diagnostics operate with either knife-edges or
slits. The knife-edge method is described in “Theory of Operation”
(p. 1-3). The Slit method is similar to the knife-edge method but uses
a very narrow slit instead of a knife-edge. These systems usually
obtain one or two high-resolution beam profiles from which accu-
rate measurements can be made. The resolution along the scanned
profiles is very high compared to camera systems, enabling resolu-
tion in “tenths of microns” instead of “tens of microns” in a camera
system. Consequently, they can measure beam widths down to
several microns. Their dynamic range is much larger than CCD
camera systems, enabling measurement at relatively high power.
They are unable to provide true representative 2D intensity contour
plots of the beam. They are unable to measure pulsed lasers, but
offer measuring capabilities at wavelengths where the CCD cameras
cannot work, utilizing sensors other than silicon.

BeamMaster-USB 
Solution

The BeamMaster-USB bridges the gap between CCD and scanning
aperture beam diagnostics. The BeamMaster-USB is based on Scan-
ning Aperture technology so it has all the benefits of a Scanning
Aperture System, but is enhanced with a patented multiple scanning
knife-edge system. Unlike standard Scanning Aperture systems, the
1 - 5
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seven scanning knife-edges and a mathematical process called
“Reconstructive Tomography” provide 2D and 3D reconstructions
of CW laser beams. Because the BeamMaster-USB uses knife-edges
as opposed to slits, it can measure laser power. BeamMaster-USB
can also measure beams up to 1 watt with its unique ability to insert
filters behind the scanning knife-edge, thus preventing distortion of
the beam measurement.
1 - 6



Setup
SECTION TWO: SETUP

In this section:

• Hardware installation (this page)

• Care and handling (p. 2-2)

• System requirements (p. 2-2)

• Installing the software (p. 2-3)

• Connecting the detector (p. 2-3)

• Selecting a filter (p. 2-4)

• Installing the USB external box (p. 2-5)

• Running the software (p. 2-8)

• Configuring the software (p. 2-10)

Hardware 
Installation

Before installing the BeamMaster-USB hardware into the
computer, make sure the PC computer system meets the require-
ments listed under “System Requirements” (p. 2-2).

NOTICE!
The BeamMaster-USB warranty is void if a power-protection
outlet (surge protector) is not used. A surge protector will
protect the BeamMaster-USB from high-voltage spikes, power
fluctuations, and surges associated with laser laboratory equip-
ment.
2 - 1
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Care and 
Handling

Detector Head The detector head is a precision instrument and should be handled
with care. If the head is dropped it may be damaged. When not in
use, keep the cap over the aperture to prevent dust from accumu-
lating on the sensor and the knife-edges. The knife-edges are deli-
cate and will be damaged if they hit any object. The filters, (if
provided) are the only objects that may be safely inserted into the
detector head. Do not remove the covers, since the internal systems
are delicate and can easily be damaged.

Filters Filters are provided with the silicon versions of the detector heads.
These filters have been precisely calibrated to a particular Beam-
Master-USB head; therefore, they share the same serial number.
Dust, scratches, and other types of contamination will degrade the
accuracy of the system. Keep unused filters in the storage case. Be
gentle when handling these fragile items—see “Selecting a Filter”
(p. 2-4) for more information.

 

Laser Safety

WARNING!
Comply with all relevant laser safety procedures and precau-
tions when using this device. The instrument will reflect a
portion of the laser light and the resulting diffuse and specular
reflections may be dangerous.

System 
Requirements

To run the BeamMaster-USB, the computer system must meet the
minimum requirements shown in the following table. Where
helpful, there are also system recommendations.

Table 2-1.  Hardware Requirements

Minimum Requirement Recommended
CPU Pentium IV Core 2 Pentium IV Core 2 Duo

System RAM 1 GB 2 GB

CD drive Required

Hard disk 200 MB free 300 MB free

Operating system Windows XP, Windows Vista, or Windows 7

Mouse Microsoft mouse or compatible pointing device

VGA 128 MB memory 512 MB memory

High speed USB 2.0 port Required
2 - 2
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Installing the 
Software

To install the software:

1. Insert the CD disk into the CD-ROM drive and wait for an
automatic start of the BeamMaster-USB installation process. 

2. Follow the on-screen instructions.

3. When the following screen appears, fill in your user name,
company name, and the system serial number (available on the
system CD).

Note: If a window similar to the one shown below appears, click
the “Install this driver software anyway” button to continue the
installation.

Connecting the 
Detector

The detector head has a cable with a 15-pin connector. The detector
cable is connected to the corresponding 15-pin connector on the
USB external box.
2 - 3
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Selecting a Filter When a Silicon head is ordered with a BeamMaster-USB, it will
come with two filters. This section will help the user determine
which filter to use. Here is the general guideline:

No filter: Power up to 5 mW

NG4 filter: Power up to 50 mW

NG9 filter: Power up to 1 W

The actual filter transmission is dependent on wavelength and can
also vary from batch to batch. The transmission values for a partic-
ular wavelength can be found in the filter files included with the
software (NG4.FLT and NG9.FLT).

Focused Spot When measuring a focused beam at a focused spot, the system will
usually need attenuation. A convenient way to determine the correct
attenuation is to first measure the power of the beam before focusing
and then focus and measure the power with the detector head using
the NG4 10%. If the power reading is low by more than 10% of the
unfocused reading, use the NG9 0.5% filter. The power densities
associated with focused beams can easily saturate the silicon
detector. A saturated detector output will result in a low power
reading.

Installing the Filters 1. Remove the blank filter plate with the supplied Allen wrench.

2. Carefully insert the desired filter

3. Secure the new filter with the Allen wrench.

NOTICE!
Dust, scratches, and other types of contamination will degrade
the accuracy of the filters. Keep unused filters in the storage
case.

Custom Filters and 
Power Calibration

A custom filter file can be made to accommodate other filters for
absolute power calibration. See help for “Create Filter File” under
the File menu.
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Installing the 
USB External Box

Windows XP 1. Plug the BeamMaster-USB external box into a high-speed
USB 2.0 port.

2. Insert the USB connector into the USB port of the computer.
When the following message appears, press the Next button.

3. Click the Finish button on the following screen.
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4. Click the Next button on the following screen.

5. Press the Finish button to complete the installation.
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Windows Vista and 
Windows 7

1. Plug the BeamMaster-USB external box into a high-speed
USB 2.0 port.

2. Insert the USB connector into the USB port of the computer.
The following messages display:

3. After completion of the installation, verify that the device was
properly installed by looking under System Properties, Device
Manager Tab (DOBAS USB Device), as shown below:
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Running the 
Software

To run the software, do one of the following:

• Click on the BeamMaster-USB icon ( ) on the desktop, or

• In Windows, click Start, select Programs, and then choose
BeamMaster-USB from the list.

The following Welcome screen is displayed:

The software will perform a hardware check and will display the
following error message if the USB manifold box is not found:

If there is no error, the software performs a test to identify the
measuring head being connected to the USB manifold box:

If the software cannot detect a measuring head, the following error
message displays:

If there is no error, the software performs a test to identify the
measuring head type being connected to the USB manifold box:
2 - 8



Setup
The screen shown below will appear only in one of the following
cases:

• Whenever a measuring head is being connected to the mani-
fold box and the calibration files in use do not match. If this is
the case, you will need to change the head S/N—refer to “Add
Detector Head” (p. 4-71) for more information.

• When the measuring head is malfunctioning. If this happens,
contact Coherent—refer to “Obtaining Service” (p. 10-2) for
contact information.

The following error message appears when the hardware test is
completed and no hardware was found. In this case, you can start the
software in Viewer/Client mode by clicking the Yes button.

Several common symptoms result from a conflict with the USB
external box. If your symptoms match one of those listed below,
proceed to the suggested section:

• Hardware failure error in the toolbar. See “System Errors”
(p. 7-1) for possible solutions.

• If the BeamMaster-USB software was working at one time and
has now stopped working, connect the USB external box to
another USB port and see if that solves the problem. If the
problem persists, contact Coherent—refer to “Obtaining
Service” (p. 10-2) for contact information.
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Configuring the 
Software

Before capturing data, configure the following settings in the soft-
ware to insure a successful first run of the BeamMaster-USB.

From the System menu, select System Setup:

• Enter the wavelength of the test source.

• Choose an industry standard Clip level (13.5 or 50%).

• You may increase the average if values vary more than
desired—refer to “Average” (p. 4-66) for more information.

• Using Run mode captures continuously and is best for general
operation. Using Step mode captures only one measurement
data when a user clicks a button.

There is no longer a configuration for “High Resolution”
measurement for beams < 100 µm, as was previously required
with the PCI version of BeamMaster. Measurements for all
beam sizes are performed in high resolution mode with the
BeamMaster-USB.
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SECTION THREE: OPERATION

In this section:

• Title bar (this page)

• Menu bar (p. 3-2)

• Tool bar (p. 3-2)

• Window area (p. 3-3)

• Status bar (p. 3-4)

• Keyboard operation (p. 3-5)

• Methods of data entry (p. 3-7)

When the BeamMaster-USB application is started, the main Beam-
Master-USB window appears. The BeamMaster-USB window
consists of display and control elements similar to most Windows
applications, along with elements specific to the BeamMaster-USB
interface.

The main elements of the BeamMaster-USB window interface are
shown in the following figure:

Title Bar The Title Bar displays the name, “BeamMaster-USB,” followed by
the detector head type and serial number. The Windows operating
system provides special controls in the title bar of a window. From
the title bar, the main window can be closed, moved, sized, mini-
mized to icon form, or maximized to fill the screen. For more infor-
mation on these controls see the Windows manual or find the
Windows Tour program.

Figure 3-1.  BeamMaster-USB Window Interface—Main Elements
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Menu Bar The Menu Bar lists menus available for the BeamMaster-USB soft-
ware. The menus listed in the Menu Bar contain items that allow
specific actions to be performed. Sub-menus or dialog boxes may
result from a menu item selection. These secondary items provide
various controls of such functions as graphics, analysis, configura-
tion setup, etc.

Selecting a Menu There are three ways to select a menu:

1. Press ALT and then the arrow keys, then Enter.

2. Hold down the ALT key and press the underlined letter (hot
key) in the desired menu item.

3. Press a shortcut key combination. Shortcuts are available for
some menu items and are displayed next to the menu item.

Tool Bar The tool bar is a collection of shortcut buttons to menu items that are
frequently used. Each shortcut is represented with a special icon
(picture) called a tool button.

To activate a tool button, place the mouse over the button and
click the LEFT mouse button. The button will change both color and
shadow to designate the function is active. To view the function of
any icon button, place the cursor on the icon and wait momen-
tarily—a brief function description will appear near the icon.

Tool Bar Buttons The following buttons are available on the tool bar:

Inactive Tool 
Buttons

If a tool is not available, it will be displayed in a gray outline form.
The Log button requires setup information to be available. The Step
button will not be available unless the system is set in Step Mode.

Start Log (disabled)

Step (disabled - so system is in RUN mode)

Figure 3-2.  Tool Bar Buttons
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Toggle Tool 
Buttons

The toggle group of tool buttons will turn display windows ON and
OFF. These tool buttons act as a toggle switch. When the corre-
sponding window is active, the button will appear to be pushed
down. When the corresponding window is not active, the button
appears in the UP position.

W profile ON

W profile OFF

Hide the Tool Bar See “Tool Bar Command” (p. 3-3).

System Errors System errors are displayed in the data and time location, when
necessary. See “System Errors” (p. 7-1) for more information.

Date and Time The current date and time are presented on the right side of the tool
bar. System errors are also displayed in the date and time location,
when necessary. See “Status Bar Panels” (p. 3-4).

Tool Bar 
Command

The tool bar can be hidden or shown by selecting Tool Bar from the
View menu, or using the Shift + Insert keyboard shortcut.

This option enables the user to toggle between Show Tool Bar and
Hide Tool Bar.

When the Tool Bar is selected (Activated), there is an additional line
on top of the window containing Tools (picture shortcuts to some of
the most commonly used system functions), along with date/time
information.

When this option is not selected, the Tool Bar line disappears. In this
case the user has to activate the various system functions from the
menu or via keyboard shortcuts.

Window Area The Window Area is utilized for the graphical display windows. The
BeamMaster-USB windows can be arranged in any configuration.
The Windows can show beam profiles, position diagrams, 2D and
3D contours, charts, and a power meter. Interactive mouse control of
each window allows a variety of customized configurations.
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Arranging 
Windows

Several special commands for arranging windows can be found
under the Windows menu. See “Windows Menu” (p. 4-72).

Status Bar The Status Bar is located at the bottom of the BeamMaster-USB
window. It indicates the current status of key system measurement,
configuration, and operational parameters.

If the BeamMaster-USB system is not operating as intended, the
Status Bar provides a quick summary of why it is not functioning
properly; for example, the laser being used may have a different
wavelength. The Status Bar is a valuable aid in diagnosing unex-
pected results and can quickly help you get back to desired opera-
tion.

The Status Bar also provides quick access to System setup
parameters. Click the current Wavelength value to access
System setup. Toggle between Run/Step modes by clicking the
current mode on the Status Bar.

Status Bar Panels Date & Time—The current date and time are presented on the right
side of the Tool Bar. This information is shown in American Stan-
dard format.

Wavelength—This panel will display the current wave-
length—refer to “Wavelength” (p. 4-65).

System Clip Level—The clip level displayed on the Status Bar
corresponds to the System Clip Level. The System Clip Level is
utilized to calculate beam diameter on the Chart window, etc. See
“Clip Level” (p. 4-66).

Average—The displayed Average value corresponds to the number
of samples averaged before calculation and display—see “Average”
(p. 4-66).

Head Tilt—The Head Tilt value corresponds to the user-entered
value for the current detector head azimuth rotation—see “Head
Tilt” (p. 4-67).

Figure 3-3.  Status Bar
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Run/Step—The Run/Step display indicates the current mode of data
collection. If the screen does not appear to update, verify that the
system is not set to Step Mode—see “Mode” (p. 4-67).

Filter—The current Filter selection is indicated. See “Create Filter
File” (p. 4-2).

Power—The Power reading display is indicated. See “Power Setup”
(p. 4-26).

To hide or show the Status bar, read the information under
“View Status Bar,” next.

View Status Bar The Status Bar can be hidden or displayed by selecting Status Bar
from the View menu or using the Ctrl+Insert keyboard shortcut.

This option enables the user to toggle between Show Status Bar and
Hide Status Bar.

When Status Bar is activated, there is an additional line appearing at
the bottom of the window. This line contains panels displaying
general system information and user settings.

Keyboard 
Operation

The keyboard can be used to enter text data or control most
BeamMaster-USB functions utilizing keyboard shortcuts.

Help Press the F1 keyboard key to obtain Help on the active window.

Selecting a Menu 
Item

Use one of the following methods to select a menu item:

• Press ALT and then the arrow keys and then Enter to select a
menu item.

• Hold down the ALT key and press the underlined letter (hot
key) in the desired menu item.

• Press a shortcut key combination. Shortcuts are available for
some menu items and are displayed next to the menu item.

Closing a Menu To close a menu, press the ESC key.
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Dialog Boxes

Text Entry Select the text box you wish to change. Use the keyboard to enter the
desired text. When the correct text has been entered, press the TAB
key to finish data entry and move to the next control in the dialog
box. If an error is made while typing text, pressing the
BACKSPACE key will remove the character to the left of the text
cursor and move the cursor to the erased location. See also “Value
Entry Box” (p. 3-8) for changing spin buttons.

ESC Key This key is used to select the Cancel button in a dialog box. This
function resets settings to their previous values before the dialog box
was opened.

ENTER Key This key is used to select the OK button in a dialog box.

TAB Key This key moves the input focus to the next control in a dialog box.

The following table summarizes all the software shortcuts and
control keys:

Table 3-1.  Software Shortcuts and Control Keys (Sheet 1 of 2)

Command Description Shortcut Icon

Load Configuration File Displays Open dialog to load a (*.ini) configuration file Ctrl+O

Save Configuration File Displays Save dialog to save a (*.ini) configuration file Ctrl+S

View File Displays Open dialog to view a log file Ctrl+V

Create Filter File Starts the Create Filter File process Ctrl+A

Print Text File
Displays an Open dialog to load and print any saved Beam-
Master-USB file in text format

Ctrl+P

Print BMP File
Displays an Open dialog to load and print any saved Beam-
Master-USB file in .bmp or .jpg format

Ctrl+B

Setup Data Collection Displays the Data Collection Setup dialog

Start Data Collection Starts the Data Collection process

Print Screen Prints the entire screen Ctrl+F12

Exit Exits the BeamMaster-USB software Ctrl+X

Add Detector Head Add Detector Head dialog Ctrl+D

Start Link Starts the RS-232 Link communication Ctrl+K

Slave Mode Activates the Slave Communication mode Ctrl+M

Help Active Window Displays Help information on current active window F1

View Power Displays Power window F2
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Methods of Data 
Entry

Check Box Use the following selection method to turn an option ON:

A check box is utilized in cases when there is a need to toggle a
parameter ON or OFF. When the parameter is active, a check mark
() is displayed inside the option box.

Place the mouse cursor at the option box and click the LEFT
mouse button. Click the LEFT mouse button again to deactivate the
selection. The check mark is than removed from inside the box.

Highlight the required parameter box by pressing the TAB
key. Press the SPACEBAR to toggle the Check Box parameter.

Profile V Displays Profile V window F3

Profile W Displays Profile W window F4

Plot Displays the Power Plot window F7

Step Increments the Step display if the system is in Step mode F9

Test Opens the Test window

Print Window Prints the current active window F12

ToolBar Toggles the Tool Bar on and off Shift+Insert

Status Bar Toggles the Status Bar on and off Ctrl+Insert

Close All Windows Closes all active windows Ctrl+W

About Displays the BeamMaster-USB About dialog Shift+F1

Search For Help For Activates the BeamMaster-USB Help search function Ctrl+F1

Table 3-1.  Software Shortcuts and Control Keys (Sheet 2 of 2)

Command Description Shortcut Icon
3 - 7



BeamMaster-USB User Manual
Radio Button Use this typical radio button entry to select a value from a short list
of options:

Move the mouse cursor and place it at the required option.
Click the LEFT mouse button once to select the option.

Move the cursor to the required option—either by moving the
mouse or by pressing the TAB key—until the cursor is within the
option list zone. Press the arrow keys to select the option from the
list.

Value Entry Box Use the Value Entry Box to set a digital value parameter:

Place the mouse cursor at either the Up or Down arrow
buttons displayed to the right of this box, and then click the LEFT
mouse button to change values for the selected parameter.

Move the cursor to the required data box either by moving the
mouse or by pressing the TAB key. Type the desired value. The
ENTER key may change the value to meet the system requirements.
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Color The Color option enables the user to set the background color, data
color, and plot color for the various windows. Select the desired
color from the standard Windows color pallet. Custom colors are
also available with the appropriate video card and Windows color
setting.

The Position, Profile W, and Profile V windows allow the selection
background, data, and plot color. The Power and Projection
windows allow for the selection of background and data color. Plot
and Chart windows allow for the selection of background and plot
colors.

Selecting a Color Place the mouse cursor over the desired Color Box and click
the LEFT mouse button once. Press and hold the Preview button to
view the selected colors without accepting the settings and exiting
the dialog.
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SECTION FOUR: MENUS AND COMMANDS

In this section:

• File menu (this page)

• View menu (p. 4-22)

• Options menu (p. 4-56)

• System menu (p. 4-64)

• Window menu (p. 4-72)

• Help menu (p. 4-73)

The following Command menus are available on the Beam-
Master-USB Menu Bar:

File Menu The File menu allows the user to perform many file operations.

The following commands and menu items are available from the
File menu:
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View File This option provides the user with the ability to view any stored file,
including: Data Log, Power Plot, Width/Position strip chart, Test,
Profile Snapshots, and .ini files.

To access this option:

1. Select the View File menu item from the File menu. Alterna-

tively, press the CTRL + V keys or click the  button on the

Tool Bar. A standard Windows file dialog will display.

2. Select the “File Type” for the file to be viewed.

The dialog will default to the BeamMaster-USB directory where the
files are typically located.

3. Click on a file from the list on the left.

4. Click OK. The file can now be displayed in the Notepad appli-
cation.

Create Filter File This option enables the user to define a new optic filter file (Filter).

To access this option:

Select the Create Filter File from the File menu or press the
CTRL + A keys.

Because silicon detectors saturate easily, it is frequently necessary to
insert one or more filters in front of the detector to attenuate the
beam and prevent saturation. The wavelength response of these
filters is not flat, so it is necessary to install the transmission proper-
ties of the Filter in the software to obtain proper power measurement
and gain setting for the detector amplifier.
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Filter File Contents

The Filter file contains a table with two columns. The first column
is the wavelength (in 1 nm, or larger, steps). The second column is
the known transmission of the filter for the corresponding wave-
length. The BeamMaster-USB software uses straight-line interpola-
tion to determine transmission values for wavelengths that lie
between wavelengths listed in the file.

Absolute Power Calibration

A filter file can be created to provide power calibration. First
measure the power of the beam with a calibrated power meter. Then
measure the reported power with the BeamMaster-USB Power
Window—see “Power” (p. 4-22)—with the Filter option OFF—see
“Filter” (p. 4-23). Now perform the following calculation and use
the % transmission value obtained when creating the filter file.

% Transmission Value = (Real Power / BM Power) * 100

Creating a New Filter File

1. Select Create Filter File from the File menu (or press the
CTRL + A keys).

2. There are 3 Value Entry boxes: line number, wavelength (nm),
and transmission value (%). The data box labeled “Number”
starts with the line number value “1”.

3. Type a value for wavelength, or change it by using the arrow
keys in this data box. If a wavelength outside the operating
range of the detector head is entered, a warning will be
displayed.

4. Type the percent transmission, or change it by using the arrow
keys in this data box.

5. Press the Add button to insert the next data line into the Filter
file. The data box labeled as “Number” will display the value
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of “2.” Go back and repeat steps 3, 4, and 5 until all the desired
wavelength/transmission points have been entered.

6. Press the arrow keys in the data box labeled “Number” to navi-
gate the entered points of the new filter file. You can use the
Remove button to delete a current point in the filter file or the
Remove All button to delete all points.

7. Press the Complete button when you are done with the Filter
creating procedure. BeamMaster-USB will then display a file
storage dialog. Press the Cancel button to cancel attenuation
data file creation.

8. In the file dialog there is no need to change the “File Type”
because FLT is the default.

9. The BeamMaster-USB data files are located in the “Data”
folder in the BeamMaster-USB directory. By default, the
BeamMaster-USB directory is located in “Program Files.”

10. Type a filename for the filter file in the box below the word
“File name”. There is no need to have the file name end in .FLT
because the program will automatically save the file with a
.FLT extension.

11. Click the Ok button.

Print Print allows the user to print an entire saved data file. Saved data
files include a pre-saved text file or a pre-saved image file.

Printing a Text File

1. Select the Print menu item from the File menu, press the

CTRL + T keys, or click the  tool bar button. 

2. Select the Text File menu item.
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3. Select the “File Type” for the file to be printed.

The BeamMaster-USB data files are located in the “Data” folder in
the BeamMaster-USB directory. The BeamMaster-USB directory is
located in “Program Files” by default.

4. Click on the desired file from the file list on the left.

5. Click the OK button. A standard print setup dialog is
displayed.

6. Select the printing variables and then click the OK button.

Printing an Image File

1. Select the Print menu item from the File menu, press the

CTRL + I keys, or click the  tool bar button. 

2. Select the Image File menu item.
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3. Select the “File Type” for the file to be printed.

4. Click on a file from the file list.

5. Click the OK button. A standard print setup dialog is
displayed.

6. Select the printing variables and then click the OK button.

Print Window Print Window enables an immediate printing of the active window.
The colored title bar indicates the current active window.

Printing an Active Window

1. Select Print Window from the File menu, or press the F12
keyboard shortcut to display a standard print dialog screen.

2. Select the printing variables and then click the OK button.
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A message box “Printing...” is displayed when the window graphics
is being transferred from the program to the printer via the Windows
Print Manager.

The time required for printing graphic screens in a Windows
environment is dependent on the computer resources.

Print Screen Print Screen enables an immediate printing of the current full screen
display.

Printing a Screen

1. Select Print Screen from the File menu, or press the
CTRL + F12 keyboard shortcut to display a standard print
dialog screen.

2. Select the printing variables and then click the OK button.
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A message box “Printing...” is displayed when the window graphics
is being transferred from the program to the printer via the Windows
Print Manager.

The time required for printing graphic screens in a Windows
environment is dependent on the computer resources (speed and
memory), on the printer’s internal memory and speed, and on
the number and type of other Window application programs
running at the time printing is initiated.

Page Setup This option enables the user to set the orientation and paper size, and
to load the appropriate driver from the standard Page Setup window.

Setting up a Page

1. Select Page Setup from the File menu to display the Page
Setup dialog screen:

2. Change the necessary parameters on the screen and then click
the OK button.
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Start/Stop Log This option enables the user to start or stop a log data file.

Starting/Stopping a Log Data File

• To start a log operation, select Start Log from the File menu or

click the  button on the Tool Bar.

• To stop a log operation, select Stop Log from the File menu or

click the  button on the Tool Bar.

Start Log is disabled until the following parameters are configured
in the Log Setup (refer to Log Setup, below, for more information):

• The duration of the experiment

• The rate of data logging

• The Log filename

When the data saving process is active, a log banner is displayed on
the top corner of the  Tool Bar area. 

During data collection, the Start Log menu item and tool bar icon
change to Stop Log.

Log Setup This setup window allows the user to customize the log operation.

Customizing the Log Operation

1. Select Log Setup from the File menu or click the  tool bar
button to display the Log Setup screen:

File Tab

• Log Type: Select the desired file type: Log file or Excel file.
The Log file is saved in a standard text format. The Excel file
is saved as an Excel Workbook.
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• File name: Click the Browse button to assign a file name and
location for the data file.

Note: When LOG file type is selected, all data collected will be
saved with the file extension *.log. The .log extension designates the
data as a text file and can be imported into other programs. When the
Excel file type is selected, data will be saved as a file name *.xls  or
*.xlsx, depending on the version of Microsoft Excel being used.
When the HTML file type is selected, data will be saved in two files
with *.xml and *.htm extensions for viewing in an Internet browser.

Settings Tab

• Log Mode: This mode selection determines the method of data
collection. The Time mode selection allows data collection at
a rate resulting from the interval and duration settings. The
Points mode sets data collection according to the specified
number of points. The Manual mode enables saving one single
measurement by pressing the Space Bar button.

• Interval: The time interval determines the time between
consecutive data points.

• Duration: The total amount of time required to complete the
data collection.

Data Tab

• Data: Allows you to select the data that will be stored in a log
file.
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When the desired setup parameters are selected, click the OK button.
The data collection process (Log file) is initiated by selecting the
Start Log menu item—refer to “Start/Stop Log” (p. 4-9).

The end of each Log file contains a statistics summary, which
includes: Minimum value, Maximum value, Mean value, and Stan-
dard deviation value for each parameter saved.

Log Setup is disabled while Log is in progress.

Press OK to confirm the selection or CANCEL to restore previous
settings.

Start Link The Start Link command provides the capability to operate an
RS-232 communication channel for serial data transmission. Any
displayed data or a pre-saved file can be transmitted when using
Start Link. Typically this feature is used to transfer real time data
from the BeamMaster-USB system to another computer over a
null-modem serial cable. The other computer can receive the data
using a program that can communicate over a COM port, like the
Windows HyperTerminal program.

Transmitting a File Over RS-232

1. Connect the BeamMaster-USB system to another computer
using a null-modem cable—see “Making a Null-Modem
Cable” (p. 4-12).

2. Before using Start Link, set the Link parameters in Link Setup.
Each link parameter must be configured to match the commu-
nications protocol of both computers receiving data.

3. Enable the receiving program to receive the data.

4. Select Start Link from the System menu. A standard Windows
File box is displayed.

5. Select the “File Type” for the file that will be sent. There
should be no need to change the directory because most files
should be stored in the default BeamMaster-USB directory.
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6. Click on a file from the file list on the left.

7. Click OK. A link status window will be displayed in the upper
left-hand corner of the Window area.

The file is transmitted in the Background while BeamMaster-USB
continues to capture data. When finished, the Linking status
message will disappear. To stop a Link in progress, select Stop Link
from the System menu.

Making a 
Null-Modem Cable

A null-modem cable can be made from a standard RS-232 cable by
connecting the pins on one end of the cable to the pins on the other
end, as shown in the following figures.

Figure 4-1.  Null-Modem with 25 Pins on Both Sides

Figure 4-2.  Null-Modem with 9 Pins on One Side and 25 Pins on the Other Side
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Link Setup Link Setup allows the user to configure the system for a particular
set of parameters needed for the RS-232 or TCP/IP transmission.
The default values are typical for this kind of transmission and are
show below.

General Tab

• Connect using: The COM port setting selects the port utilized
for RS-232 transmission from the BeamMaster-USB-based
computer.

Figure 4-3.  Null-Modem with 9 Pins on Both Sides
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Transmit: The Transmit radio button selection toggles the transmis-
sion type between transmit a file and real-time data.

Port Settings Tab

Use the settings on this tab to set RS-232 serial parameters.

• Bits per second: This selection determines the transmission
rate (baud rate) of the data transmission. See “Bits per second”
(p. 4-16).

• Data bits: The Data Bits selection determines the number of
data bits utilized for transmission. See “Data Bit” (p. 4-17).

• Parity Bits: This selection determines the parity bit utilized
for robust serial communication. See “Parity Bit” (p. 4-18).

• Stop bits: This selection determines the number of stop bits
utilized for transmission. See “Stop Bit” (p. 4-19).

• Handshake: Specifies the control protocol used in estab-
lishing a serial port communication. See “Handshake”
(p. 4-20).

Press OK to confirm the selection or CANCEL to restore previous
settings.
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Port The Port selection option is accessed from Link Setup—refer to
“Link Setup” (p. 4-13).

The Port setting is utilized to set the computer communication
(COM) port for RS-232 data transmission or to choose TCP/IP
transmit data method. This setting should only be changed when
utilizing the RS-232 or TCP/IP communication link.

Transmit The Transmit option is accessed from Link Setup—refer to “Link
Setup” (p. 4-13). This setting should only be changed when utilizing
the RS-232 or TCP/IP communication link.

The possible values for Link transmission port are: File and Data.
Selection is made with radio buttons—see “Radio Button” (p. 3-8).

The Transmit setting is selected for either on-line transmission of
live data, or transmission of a pre-saved text file. When data is
selected, the system will send the following data, depending on the
active window:
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$ Time (x.x), Power (x.xxx), PositionX (x.x), PositionY (x.x),
WidthV (x.x), WidthW (x.x), WaveValue, ClipLevel, Average,
FilterName, SystemNumber

For example:

$ 2.4 0.375 230.5 400.1 1234.4 2345.5 633 13.5 4 NG4.FLT BM715

Note: To stop a link in progress, select Stop Link from the System
menu.

Bits per second This setting is accessed from Link Setup—refer to “Link Setup”
(p. 4-13). This setting should only be changed when utilizing the
RS-232 communication link.

Bits per second refers the transmission rate for the RS-232 link. The
possible values are: 110, 300, 600, 1200, 2400, 4800, 9600, 19200,
38400, 57600, and 115200.

This setting must match the corresponding setting on the receiving
computer.
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Data Bit The RS-232 data bit selection is accessed from Link Setup—refer to
“Link Setup” (p. 4-13). This setting should only be changed when
utilizing the RS-232 communication link.

This setting determines the number of bits utilized for RS-232 trans-
mission. The possible values are: 4, 5, 6, 7, and 8.

This setting must match the corresponding setting on the receiving
computer.
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Parity Bit The Parity Bit option is accessed from Link Setup—refer to “Link
Setup” (p. 4-13). This setting should only be changed when utilizing
the RS-232 communication link.

This setting determines whether or not a parity bit is to be trans-
mitted. The possible values are: None, Odd, Even, Space, and Mark.

This value must match the corresponding setting on the receiving
computer.
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Stop Bit The Stop Bit option is accessed from Link Setup—refer to “Link
Setup” (p. 4-13). This setting should only be changed when utilizing
the RS-232 communication link.

This setting determines the number of stop bits to be transmitted.
The possible values are: One, Two, or OnePointFive.

This value must match the corresponding setting on the receiving
computer.
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Handshake The Handshake option is accessed from Link Setup—refer to “Link
Setup” (p. 4-13). This setting should only be changed when utilizing
the RS-232 communication link.

This setting must match the corresponding setting on the receiving
computer.

• None: No control is used for the handshake.

• XOnXOff: The XON/XOFF software control protocol is used.
The XOFF control is sent to stop the transmission of data. The
XON control is sent to resume the transmission. These soft-
ware controls are used instead of Request to Send (RTS) and
Clear to Send (CTS) hardware controls.

• RequestToSend: Request-to-Send (RTS) hardware flow
control is used. RTS signals that data is available for transmis-
sion. If the input buffer becomes full, the RTS line will be set
to false. The RTS line will be set to true when more room
becomes available in the input buffer. 

• RequestToSendXOnXOff: Both the Request-to-Send (RTS)
hardware control and the XON/XOFF software controls are
used. Specifies the control protocol used in establishing a
serial port communication.
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Slave Mode After selecting the Link Setup parameters, the user can activate the
Slave Mode option from the File Menu. The keyboard shortcut for
Slave Mode is CTRL + M.

Transmit parameter should be selected as Data.

After selecting the Slave Mode option, a status label will be
displayed in the upper right-hand corner of the Tool Bar  area.

To receive transmitted data at the master computer, either press the
d key on the keyboard, or send the BeamMaster-USB program an
ASCII code for d.

To terminate Slave Mode, unselect this option in File Menu (termi-
nate the Slave Mode from the BeamMaster-USB program). The user
can terminate the Slave Mode from the master computer by either
pressing the s button, or sending ASCII code to the slave computer.

The receiving program at the master computer is not provided with
the BeamMaster-USB product. It should be written according to the
user's application needs.

Exit The Exit function is selected from the File menu—refer to “File
Menu” (p. 4-1). The keyboard shortcut is CTRL + X.

Use this option to terminal the BeamMaster-USB application.

The following dialog is shown when you exit the program and Save
Settings on Exit is not enabled—refer to “Options Menu” (p. 4-56)
for information about the Save Settings on Exit option. It is a
reminder to save the current setup parameters.

Select Yes to exit and save current user settings.
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View Menu The View menu operates the functional windows. The following
commands and menu items are available from this menu:

The corresponding keyboard shortcuts are shown to the left of the
item. These shortcuts may be activated from the Main window by
pressing the appropriate keyboard combination.

A check mark in front of a menu item indicates that the function is
active.

A gray menu item indicates that item is unavailable. Conditions or
Setup parameters may be required for the item to be active. Review
other text in this manual text or help associated with the gray item
for additional setup information.

Power The Power window can be turned ON or OFF by choosing Power

from the View menu, pressing the F2 keyboard shortcut, or clicking

the  tool bar button.
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The Power selection activates the power meter display window. The
display shows real-time power as a needle graph or a digital value.
Several buttons provide easy and quick control of the Power func-
tionality.

Placing the mouse cursor over the Power display and pressing the
left-hand mouse button twice changes the Position window to a
graphical presentation, only without the measurement data display
on the right-hand side of the window.

The power units can be selected by clicking on the units displayed
in the Power window. Each mouse click will cycle to the next unit
(µW, mW, and dBm).

Power Buttons

Filter: The Offset button will load or unload a pre-defined transmis-
sion file into the power calculation.

Null: The Null button will activate or deactivate the ambient-light
suppression.

Setup: The Setup button will display the Power Setup dialog
containing various power related settings.

To get help on this window, press the F1 key when Window is
active. The Active window is the window with the highlighted
title bar.

Filter The Filter button is accessed from the Power window.

This button is not available when BeamMaster-USB is used with
the InGaAs detector head.

Because silicon detectors can saturate very easily, it is frequently
necessary to insert a filter in front of the detector. The filter will
attenuate the beam and prevent saturation. Since the wavelength
response of the filter is not flat, it is necessary to install the transmis-
sion properties of the filter in the software to obtain a proper power
measurement. The proper gain settings for the detector amplifier are
also determined by the actual sensor output. the filter option allows
the user to load or remove any pre-defined filter transmission file to
be utilized by the power measurement function.
4 - 23



BeamMaster-USB User Manual
Choosing a Filter File

The silicon detector heads come with two pre-defined filter files
(NG4 and NG9). For more information—refer to “Selecting a Filter”
(p. 2-4). A custom filter file can be created through the Create Filter
File command in the File menu. This is helpful if you want to cali-
brate the BeamMaster-USB system for accurate power measurement
relative to a known instrument at a specified wavelength.

Selecting the Filter File

To inform BeamMaster-USB which filter is installed in the detector
head, click on the Load button in the Power Setup dialog. A file list
is displayed, presenting all the available filter files. Select the
desired filter file and confirm with the OK button.

Using the Filter

1. Physically install the selected filter into the BeamMaster-USB
head—see “Care and Handling” (p. 2-2).

2. Click the Filter button on the power meter panel display to
activate the selected filter file. The power measuring function
will calculate power utilizing the selected filter file. A banner
containing the selected filter file name will appear in the power
display.

3. Click the Filter button on the power meter panel display again
to deactivate the selected filter.

4. Physically remove the filter from the detector head.

Null The Null button is accessed directly from the Power window.

This button provides for ambient-light suppression to permit accu-
rate analysis of the light source. When Null is not active, the value
displayed in the Power window is the total power incident on the
detector surface. When Null is active, the value displayed in the
Power window is the power of the input only.

To activate or deactivate Null, place the mouse cursor over
the Null button and click the LEFT mouse button.
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Suppressing Ambient Light

When activating Null, a message box appears, instructing the user to
remove the light source and press OK.

The system now measures the ambient light level. Clicking the OK
button will cause the software to subtract the measured level from
the subsequent measurements.

The final prompt will indicate when the measurement has taken
place and the laser can be turned on again. The OK button will acti-
vate the Null.

An “Null” banner appears in the power display with the calculated
value of ambient light displayed underneath.
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Power Setup Power Setup is selected from the Setup button in the Power window.

Power Setup allows the user to configure the power measurement
capability of the Power window.

• Units: Select the appropriate units (mW, µW or dBm) for the
power meter display.

• Filter: The Load Filter button displays a Windows open dialog
that allows the user to select the .FLT file corresponding to the
installed filter.

• Display: The Display radio buttons allow the user to select the
desired presentation.

• Status Power: Toggles between displaying the power reading
on the Status Bar and disabling the power reading display.

• Range: The Power Range selection allows the user to specify
the display range. Select the values appropriate to the current
laser power.

• Alarm Limits: The On/Off box must be checked to access the
Alarm Limit values. Set the desired values for visual alarm
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indicators in the Power Window. A Computer beep will also be
active if the Sound box is checked.

• Colors: The Colors tab allows the user to specify background
and foreground colors for the Power window. A standard
Windows color pallet is available.

Upon selecting the required parameter value, press the OK button to
confirm the selection, press Cancel to restore the previous settings,
or press System to reach the System Setup.

Units

The Units are selected from the Power Setup dialog.

The Units option enables changing the units on the power meter
display. The possible values are: mW, µW, and dBm.

Both the needle scale and the numerical power display are updated.

Set the desired power units with the radio button—see “Radio
Button” (p. 3-8). The units can also be selected by clicking on the
units displayed in the Power window. Each mouse click will cycle to
the next unit (µW, mW, and dBm).

Display

Select the Display option from the Power Setup dialog.

This option provides three types of presentations for the power
meter:

1. A graphical needle graph and a small digital presentation of the
measured power.
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2. A large digital presentation for better visibility at a distance.

3. A bar graph presentation of the measured power.

For the appropriate display, check the radio button—see “Radio
Button” (p. 3-8).

Range

Select the Power Range from the Power Setup window.

The Power Range magnifies the beam power display. The needle
graph display is affected accordingly.

This is a useful feature when monitoring small changes in beam
power.

Define the Zoom area by setting the minimum and maximum power
levels from Min or Max box utilizing the Value Entry Box.

Colors

The color option enables the user to set the background color, data
color, and plot color for the various windows. Select the desired
color from the standard Windows color pallet. Custom colors are
also available with the appropriate video card and Windows color
setting.
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The Position, Profile W and Profile V windows allow the selection
of background, data, and plot colors. The Power and Projection
windows allow for the selection of background and data colors.  Plot
and Chart  windows allow for the selection of background and plot
colors.

To select a color: Place the mouse over the desired color box and
click the LEFT button once. Press and hold the Preview button to
view the selected colors without accepting the settings and exiting
the dialog.

Alarm Limits

The Alarm Limits are selected from the Power Setup dialog.

The limits are defined by the area within the needle graph display.
Audible and visual indicators will warn the user if the power drifts
outside the user-specified zone. The allowed zones are marked in
black, while non- permitted operation zones are marked in red on the
needle graph. When the On/Off box is checked, visual indicators are
provided when the user-specified limits have been exceeded. The
Sound box provides additional audio beeps when the specified limits
have been exceeded.

Alarm Limits Options

• On: Set Alarm Limits ON or OFF using the Check Box.

• Sound On: The Sound option is used for generating an audible
warning in case the measured power exceeds the preset Alarm
Limits levels.

• Min: The Min option is used for setting the minimum range
value for Alarm Limits

• Max: The Max option is used for setting the maximum range
value for Alarm Limits.

The minimum value set for Alarm Limits should be bigger than,
or equal to, the minimum value set for Range. The maximum
value set for Alarm Limits should be smaller than, or equal to,
the maximum value set for Range.
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Sound On

Select Sound On from the Power Setup dialog.

Use this option to enable an audible warning when power drifts
outside the pre-set Max and Min alarm limits. Toggle between
Sound On and Sound Off using the Check Box.

Min

Select Min in the Power Setup dialog. The min setting is displayed
in the “Range and Limits” tab.

The minimum setting corresponds to a user-selected minimum
power level. The Min setting in the Range dialog section will set the
minimum value displayed on the power scale. The Min setting in the
Alarm Limits dialog section will be displayed on the Power
Window.

When the Alarm is active and the appropriate Min/Max levels
are set, the user will be notified when these limits are exceeded.

Max

Select Max in the Power Setup dialog. The max setting is displayed
in the “Range and Limits” tab.

The maximum setting corresponds to a user-selected maximum
power level. The Max setting in the Range dialog section will set the
maximum value displayed on the power scale. The Max setting in
the Alarm Limits dialog section will be displayed on the Power
Window.

When the Alarm is active and the appropriate Min/Max levels
are set, the user will be notified when these limits are exceeded.
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Profile V The Profile V window can be turned ON and OFF  by choosing the

Profile V menu item from the View Menu, pressing the F3 key, or

clicking the  tool bar button.

The Profile Window graphically displays details of the beam's inten-
sity profile along the V axis. In addition to the profile information,
there is a display of beam width at three different clip levels. The clip
levels (80%, 50%, and 13.5%) may be changed using the Setup
button.

• Placing the mouse cursor over the Profile display and pressing
the left-hand mouse button twice changes the position window
to a graphical presentation without the measurement data
display.

• Placing the mouse cursor over the Profile display and pressing
the left-hand mouse button twice changes the modified posi-
tion window back to its original size and shape.

Profile Buttons

• Gaussian: The Gaussian selection compares the displayed
profile to an ideal Gaussian in real time.

• Zoom: The Zoom function increases or reduces the displayed
X-Axis range (spatial resolution). The profile peak will remain
centered on the display when the Zoom is changed.

• Setup: The Setup selection provides access to the profile
settings including: background color, grid lines, auto-scaling
of the profile peak, and Supplementary clip level adjustment.

To get help on this window, press the F1 key when the Window
is active. The Active window is designated with the highlighted
title bar.
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Gaussian Select the Gaussian button from the Profile window or via the check
box in Profile Setup.

This function determines how closely the measured beam profile
matches a theoretical Gaussian profile. When the Gaussian button is
activated, a Gaussian profile is overlaid on top of the current
measured profile in real time. The gaussian fit profile is in red.

The percent correlation and width comparisons utilize the
currently-selected clip levels. The comparison data is displayed
adjacent to the profile data. The comparison data includes data about
the ideal Gaussian profile beam width, as well as the deformation
from the ideal Gaussian beam.

To turn Gaussian Off, press the Gaussian button again.

Profile Zoom Profile Zoom buttons are selected from the Profile windows.

This option allows the displayed X-axis range (spatial resolution)
Profile to zoom in or zoom out by a factor of two. The Beam-
Master-USB software will maintain the display with the peak
centered on the window.

Each time the Up/Down arrow button is clicked, the profile
displayed area is increased or decreased by a factor of two.
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Profile Setup Select the Profile Setup button from the Profile window.

Settings Tab

• AutoScale: The AutoScale selection forces the profile to be
displayed utilizing the full height of the profile window.

• Grid: The Grid selection displays a grid pattern behind the
profile. The grid is used to provide a visual point of reference
on the displayed profile.

• Gaussian: The Gaussian selection will provide a pure
Gaussian reference overlay on the displayed profile. The
Gaussian selection also provides a numeral Gaussian reference
value.

• Digital: The Digital selection will display the current measure-
ment results as digital values only.

• Clip Levels (%): This selection defines the clip levels for the
two supplementary beam width measurements.

• Colors: The Colors tab allows the user to specify background,
foreground and profile colors for the Profile Window. A stan-
dard windows color pallet is available for color selection.

All settings work independently in both the W profile and the V
profile. AutoScale can be ON for one profile window and OFF in
the other profile window.
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Autoscale

Profile Autoscale is accessed by clicking the Profile Setup button in
the display windows.

This option enables the user to toggle between Autoscale On and
Autoscale Off. 

Use the Check Box to turn Autoscale ON. When Autoscale is ON
the beam intensity profile is always normalized to fit 100% of the
display window.

Autoscale must be ON for the clip level bars to be visible.

When Autoscale is OFF, the beam intensity profile is not normalized
to 100% of the display window and the beam peak is observed as it
changes. The function is helpful during a focusing process. The peak
intensity changes may be observed as a function of the focus,
showing the variations in the beam’s peak with respect to the
changes in beam size.

This function affects only the graphical presentation on window.

Profile Grid

The Profile Grid is set from the Profile Setup dialog.

The Profile Grid option turns on the grid pattern displayed in the
profile window.

Use the check box to toggle the grid between ON and OFF.

Clip Levels

Clip Levels are selected from Profile Setup windows.

The three clip levels determine the levels at which the width of V
and W profiles are to be measured by the BeamMaster-USB system.
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A clip level defines the percentage of the peak intensity profile at
which the beam is measured. For example, a clip level of 50% indi-
cates that the beam is to be measured at its full width at half
maximum (FWHM); whereas, a clip level of 13.5% measures the
beam at a point which is 13.5% of the profile peak. The 13.5% level
corresponds to the 1/e2 point of a Gaussian profile.

Both V and W profile windows simultaneously display the width of
the beam at three clip levels. If AutoScale is ON, the display
includes three clip levels represented by solid horizontal lines super-
imposed on the profile. The default setup of clip levels is 80%, 50%
and 13.5%.

Changing Clip Levels in the Profile Setup Window

The three clip levels are labeled I, II, and III. Change the clip level
value for each one of them by entering a new value in the Value
Entry Box. The clip levels may be set in 0.1% increments.

Changing Clip Levels in the Profile Window

Place the mouse cursor just above or below the width level bar to be
changed, then press the LEFT mouse button and drag it up or down,
while watching the change in Clip Level setting on the profile
presentation. The clip level can be moved vertically to a new clip
level in 0.3% increments. When performing this operation it is
helpful to size the Profile Window as large as possible.

Profile W The Profile W window can be turned ON and OFF  by choosing the

Profile W menu item from the View Menu, pressing the F4 key, or

clicking the  tool bar button.

The Profile Window graphically displays details of the beam’s inten-
sity profile along the W axis. In addition to the profile information,
there is a display of beam width at three different clip levels.

Review the functions associated with the Profile V window for addi-
tional information.
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Position The Position window can be turned ON and OFF  by choosing the

Position menu item from the View Menu, pressing the F5 key, or

clicking the  tool bar button.

The Position function provides a real-time display of the beam
centroid position, as well as a beam foot print. This window can be
used to align the detector head with the incoming laser beam.
Settings can also be customized by clicking the Setup button.

In the main window area, the detecting area of the sensor is repre-
sented by a 9x9 mm square for the BM-7 Si Head, by a 5 mm diam-
eter circle for the BM-3 Si version, and by a 3 mm diameter circle
for the BM-3 InGaAs version. Review the current head specifica-
tions for input aperture values not previously given.

The solid cross hair target that appears within the main display area
represents the local Earth reference frame. This reference display
remains fixed. The intersection of these two solid lines is the center
of the detector. The diagonal lines labeled V and W are the axes
along which the width and profile measurements are made and
displayed.

When a laser beam enters the aperture of the head, it is represented
as a dotted ellipse. If the beam is circularly symmetric, a dotted
circle will appear. This ellipse indicates the “footprint” of the beam
in the plane of the rotating knife-edges. The ellipse will change
shape and orientation as the beam expands and contracts in different
directions. A small cross indicates the location of the center of the
beam. The X and Y coordinates of this cross are shown in µm units
under the title “Centroid.” There is also a display box that contains
an estimate of the size of the major and minor axes of the ellipse, as
well as the angle of orientation (under the title: Ellipse Data).

Placing the mouse cursor over the Position display and pressing the
left-hand mouse button twice changes the position window to a
graphical presentation without the measurement data display on the
right-hand side of the window.
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Placing the mouse cursor over the Position display and pressing the
left-hand mouse button twice changes the modified position window
back to its original size and shape. Also, any attempt to resize the
Position screen retains the original size and shape.

These values are merely estimates and are less accurate than
width measurements made in the Profiles functions.

To get help on this window, press the F1 key when the Window
is active. The Active window is the window with the highlighted
title bar.

Position Setup Select Position Setup from the Position window.

• Zoom: The Zoom selection activates the zooming capability
of the position display. Small beams are enlarged and centered
on the plot.

• Grid: The Grid selection enables a grid pattern on the position
display.
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Digital: The Digital selection displays the position data as a digital
display only.

• Zoom: The Zoom selection activates the zooming capability
of the position display. Small beams are enlarged and centered
on the plot.

Position Zoom

The Position Zoom is adjusted from the Position Setup window.

The Position Zoom is used to view the footprint of small beams
more clearly. It is recommended that this option be activated for
beam widths of less than 300 microns. Once activated, the area
immediately surrounding the beam is magnified to show the foot-
print in the greatest possible detail. The size of this region is auto-
matically scaled up or down as the beam changes size.

The “ZOOM ON” message is displayed inside the position screen
area.

Toggle between Zoom Position ON and Zoom Position OFF with
the check box.

Position Grid

The Position Grid is selected from the Position Setup window.

This option turns on the grid pattern that is displayed in the position
plot area.

Use the check box to turn the grid ON.
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Projection • The Projection window can be turned ON and OFF by

choosing the Projection menu item from the View menu,

pressing the F6 key, or by clicking the  button on the tool

bar.

The 3D image can be rotated along the vertical and horizontal axes
using the following routine:

1. Place the mouse cursor over the 3D image.

2. Hold the left mouse button down (note that the mouse cursor
shape has changed).

3. Drag the mouse while pressing the left mouse button. You can
move the cursor up or down, as well as left or right. The image
will rotate accordingly.

Placing the mouse cursor over the Projection display and pressing
the left-hand mouse button twice changes the window to a graphical
presentation without the measurement data displayed on the
right-hand side of the window.

Placing the mouse cursor over the Projection display and pressing
the left-hand mouse button twice changes the modified position
window back to its original size and shape.

The Projection function provides either a two-dimensional view or a
three-dimensional view of the beam intensity profile.

The Projection Window has a Setup button for setting the parameters
associated with this presentation.

The Projection is created using a mathematical process called
“Reconstructive Tomography.” The displayed resolution is 32*32,
regardless of beam size. This same type of process is used by X-ray
systems to create X-ray images. More knife-edges will yield a
greater level of detail. For a beam distribution that is significantly
non-gaussian, the standard seven knife-edge system can reconstruct
4 - 39



BeamMaster-USB User Manual
a plot that closely matches the real beam. When examining
near-gaussian beams, three knife-edges can give an accurate inten-
sity distribution.

To get help on this window, press the F1 key when the window is
active. The active window is indicated with the highlighted title
bar.

Projection Setup The Projection Setup button is selected from the Projection window.

• Axes V/W: The Axes selection activates the axis orientation
symbol.

• Grid: The Grid selection activates the 2D window grid.

• Digital: This selection displays the measurement results as a
digital display only.

• Dimension: The selection toggles between 2D displays and
3D displays.

• Rotation: The Rotation selection allows the user to change the
current rotation angle on the 3D display. When Auto-Rotate is
selected, the 3D display will rotate continuously at the
user-specified step increment. When Auto-Rotate is not
selected, the angle of rotation can be set numerically. 

• Tilt: The Tilt setting allows the user to specify a numerical
value for the 3D plot tilt. Place the mouse cursor over the
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currently displayed 3D plot and hold the left mouse button
down. Drag the mouse cursor to display the 3D plot at the
desired rotation and tilt angle.

• Wire Density: The Wire Density radio buttons allow for the
selection of three separate 3D plot wire densities.

• Projection: The Projection check buttons allow for the selec-
tion viewing of  3D figure projections on XZ and YZ planes.

• Colors: The Colors tab allows the user to specify background
and data colors for the Projection Window. A standard
Windows color pallet is available.

Upon completing the desired setup, click the OK button to confirm
the selection, click Cancel to restore the previous settings, or press
the System button to reach the System Setup.

Axes

The Axes Direction indicators are selected from the Projection
Setup dialog. This dialog can be accessed with the Setup button in
the Projection window.

When activated, this function displays the orientation of the V and
W axes.

Turn the Axes legend ON and OFF with the check box.

Projection Grid

The Projection Grid is toggled from inside the Projection Setup
dialog.

This selection toggles the grid pattern in the position plot area. This
setting is only available for the 2D projection.

Use the check box to turn the grid ON.
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Dimension

The Dimension setting is selected from the Projection Setup
window.

The Projection window can display the beam intensity profile in two
dimensions or in three dimensions. This function is used to toggle
between the 2D and 3D representations by utilizing the radio
buttons—see “Radio Button” (p. 3-8).

Both the 2D and 3D views are mathematical constructions based on
the profile information obtained from the knife-edges.

Figure 4-4.  Example of 2D Resolution

Figure 4-5.  Example of 3D Medium Wire Density
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3D Features

This option can be activated from the Projection Setup window.

• Rotation: The Rotation function affects the optical axis or
azimuth of the 3D display.

Adjust the viewing angle using the Value Entry Box. The
possible values for the Rotation Angle are 0 through 360
degrees. The Rotate Angle value can only be changed
when the Auto Rotate box is not selected. The projection
can be made to rotate automatically with a selected step
interval by utilizing the Auto-Rotate check box. When
the Auto Rotate box is selected, the step increment can be
set to the desired value.

• Tilt: The Tilt function selects the tilt viewing angle of the 3D
plot. The 3D plot can be viewed at horizontal tilt angles
between 0 and 90 degrees in 1-degree increments. The hori-
zontal tilt angle can be entered in the Value Entry box.

Free adjustment of rotation and tilt angle is accomplished by
placing the cursor over the graphical 3D display while
holding the left mouse button down. Movement with the
left mouse button down will adjust the tilt and rotation
simultaneously.

• Wire Density: This selection determines the number of wires
utilized to construct the 3D plot. The high-density setting can
affect the update rate of the displayed 3D profile, based on the
performance of the computer system and video card.

• Projection: The Projection check buttons allow for the selec-
tion viewing of  3D figure projections on XZ and YZ planes.

When all the desired parameters are set, click the OK button to
confirm the selection, click Cancel to restore the previous settings,
or press the System button to reach the System Setup.
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Rotation Angle

Rotation is adjusted from the Projection Setup dialog.

The Rotation function is used to change the viewing angle of the 3D
projection. The rotation takes place about the optic axis or azimuth
of the 3D display

Adjust the rotation angle with the Value Entry box. The possible
values for the Rotation angle are 0 through 360 degrees. When
Auto-Rotate is On, the user can set Step increment between 1 and 30
degrees. The Auto-Rotate function will rotate the 3D display contin-
uously at the user-specified step increment. When Auto-Rotate is
Off, the user can set Rotation Angle to any desired value between
0 and 360 degrees.

Place the mouse cursor over the currently displayed 3D plot and
hold the left mouse button down. Drag the mouse cursor to display
the 3D plot at the desired rotation and tilt angle.

The projection can be made to rotate automatically in 5-degree
increments by selecting the Auto check box.

Plot • The Plot window can be turned ON and OFF by choosing the

Plot menu item from the View menu, pressing the F7 key, or

by clicking the  button on the tool bar.

The Plot window provides a graphical display of beam power versus
time. The graph presentation includes the temporal power fluctua-
tions and provides a way to observe long-term power fluctuations.
The Plot window also displays the number of points accumulated,
elapsed time clock, and the exact time/division partition.
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• Pause: The Pause button is used to temporarily stop power
logging. Press the button again to continue.

• Reset: The Reset button is used to reset all accumulated data
(history displayed in the current session).

• Save: The Save button is used to save the current or the most
recent 500 measurements displayed. 

• Setup: The Setup button is used to set the relevant Plot Setup
parameters.

To get help on this window, press the F1 key when it is the active
Window. The Active window is the window in the window area
with the highlighted title bar.

Reset The Rest button is accessed from the Plot or Chart windows.

The Reset option enables the user to reset all accumulated data for
the Plot/Chart functions in the current session (Restart operation).

To activate Reset, place the mouse cursor over the Reset button and
click the LEFT button once. The Plot/Chart graph will redraw after
the Reset. The current accumulated data points are discarded.

Save Plot The Save button is accessed from the Plot window.

This option enables the user to save up to 500 data points. Several
plot files can be saved during the same session.

Data is saved as text in a file named *.PLT or as an Excel file named
*.XLS. The plot file name is created automatically, when the “Auto-
matic” option is  selected in the Plot Setup > Create File Name
option. The file name is composed of the date and time in the
following format:

ddhhmmss.PLT

Where dd = day, hh = hour, mm = minutes, ss = seconds.

The default automatic file name can be changed later. On this
process will allow uninterrupted data collection.

Plot File Format

The data is stored in TEXT file format and contains the following
data:

• General details like system name and date.

• A table of time values paired with the displayed power value
in milliwatts.
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Plot Setup Plot Setup is selected from the Setup button in the Plot window.

• Range: The Range tab provides control to allow the user to
specify the vertical plot scale.

• Units: The Units selection control works in conjunction with
the Range selection for vertical scale selection.

• Time: The Time control allows the user to specify the rate of
data collection.

• Colors: The Colors tab allows the user to specify background
and plot colors for the Plot window. A standard Windows color
pallet is available.

When all the desired parameters are set, click the OK button to
confirm the selection, click Cancel to restore the previous settings,
or press the System button to reach the System Setup.
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Plot Range

The Plot Range is selected from inside the Plot Setup window.

The vertical scale of the Plot graph can either be automatically
scaled or held at a user-specified value.

When AutoRange is activated, the system continuously adjusts both
the minimum and maximum limits of the Plot. AutoRange is
designed to display the greatest amount of detail on the window.

When AutoRange is turned off, the system leaves the scale at the last
auto scale setting, and manual control of the scale can be introduced.
Use the Min and Max values using the Value Entry Boxes for the
appropriate scale adjustment. When adjusting the Min and Max
values, avoid a situation where large measurement fluctuations may
go beyond the maximum and minimum vertical scale. The Off Scale
value will be displayed as flat lines at the top or bottom of the scale.

Plot Units

The Units are selected from inside the Plot Setup dialog.

The user can toggle between mW and µW units for the Plot presen-
tation. Select the units with the radio buttons—see “Radio Button”
(p. 3-8).

Time Scale

The Time Scale is selected from inside the Plot Setup dialog or the
Chart Setup dialog.

The rate at which the BeamMaster-USB software plots the data is
controlled with this setting. Set the desired Sec/div value via the
value entry box.
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The Time scale will change the horizontal scale of the Strip charts.
The value can be changed in one-second increments. The fastest
possible rate of display is 0.2 sec, which corresponds to the
maximum 5 Hz update rate. The displayed data corresponds to a
5 Hz collection rate even though the display may not update at that
rate.

Chart • The Chart window can be turned ON and OFF by choosing the

Chart menu item from the View menu, pressing the F8 key, or

by clicking the  button on the tool bar.

The Width/Position Chart window provides a real-time strip chart
display of beam position (X,Y) versus time, or beam width of V and
W profiles measured at the System Clip Level.

These charts enable the user to observe long-term beam position
stability or beam width variations. The Chart window graphically
displays the absolute position or width versus time, the number of
points accumulated, elapsed time clock, and the exact time/division
scale increment. The Setup button is used to set chart scaling and
color options. The data can also be saved as a text file for external
analysis.

• Pause: Click the Pause button to interrupt the data collection.
The current data is not lost when you use this function. When
the Pause button is selected, it changes to a Continue button to
resume data collection.

• Reset: Click the Reset button to clear the current data. 

• Save: Click the Save button to save the current data, up to the
most recent 500 points collected. The Save functions automat-
ically assigns a file name corresponding the current date and
time with a .crt or .xls file extension.
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• Setup: Click the Setup button to access all of the Chart Setup
parameters. The setup parameters allow the user to set the data
collection interval, vertical chart scale, and colors.

To get help on this window press the F1 key when it is the active
Window. The Active window is the window in the window area
with the highlighted title bar.

Save Chart The Save Chart button is selected from the Chart window.

This option enables the user to save up to 500 data points from the
current session. The user can save several chart files during the same
session.

Data is saved as text in a file named *.PLT or as an Excel file named
*.XLS. The chart file name is created automatically (when option
"Automatic" is selected in Chart Setup > Create File Name option).
The file name is composed of the date and time as follows:

ddhhmmss.CRT

Where dd = day, hh = hour, mm = minutes, ss = seconds.

The default file name can be changed later. This process will allow
uninterrupted data collection.

Chart File Format

The data is stored in TEXT file format and contains the following
information:

• General details, like the system name and date.

• Time values paired with the displayed X & Y Position values,
or

• A table of time values paired with the displayed V & W Width
values.

All dimension values are in microns.

Example Chart File

Chart File Data

BeamMaster USB, Version 1.03

File: C:\PROGRA~1\BM1035\10160540.crt

Date: 10 Mar 2005

Time: 16:05:40
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S/N: 1035

Average: 1

Wavelength: 1300(nm)

Clip Level: 13.5%

Time Width W Width V

(sec) (µm) (µm)

0.0 1682.566 2215.905

1.1 1661.088 2248.827

etc.

Chart Setup Chart Setup is selected from the Setup button in the Chart window.

• Range: Select a range for the Y axis of the Chart. The
Auto-Zoom box will control the Y axis mode. When the box is
checked, the chart’s Y axis is automatically scaled by the soft-
ware. When the Auto-Zoom box is not checked, the user can
set the Y scale with the minimum and maximum value entry
boxes in the dialog. Data that occurs outside of the
user-entered manual scale settings will be plotted as a straight
line at the top or bottom of the scale, as appropriate.

• Options: Selects either Position or Width versus Time Charts.
The position selection will graphically display the absolute
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position data vs. time in a strip chart form. The Width selection
will graphically display the beam width vs. time in a strip chart
form. Verify the range selection before exiting the Chart Setup
screen.

• Time scale: The Time selection sets the horizontal scale on the
strip chart. The horizontal scale contains 20 divisions.
Multiply the Time value by 20 to determine the amount of time
utilized for a complete chart display.

• Create File: Select Automatic or Manual, for the name
creation of the chart data file.

• File Type: Select the desired file type (Log  or Excel). The Log
file is saved in a standard text format. The Excel file is saved
as an Excel Workbook.

• File Name: If you select Manual mode in Create File, click the
Browse button to assign a File name and path for the chart data
file.

• Colors: The Colors tab allows the user to specify Background,
Width V,W, or Position X,Y colors for the Chart window. A
standard Window color pallet is available.

When all the desired parameters are set, click the OK button to
confirm the selection, click Cancel to restore the previous settings,
or press the System button to reach the System Setup.
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Chart Range

The Chart Range is selected from inside the Chart Setup window.

The vertical scale of the Chart graph can either be automatically
scaled (using the AutoRange option), or be held at a constant value.

When AutoRange is activated, the system continuously adjusts both
the minimum and maximum limits of the Chart to display the
greatest amount of detail on the window.

When AutoRange is turned off, the system leaves the scale at the last
autoscale setting, and manual control of the scale can be introduced,
using the Min and Max values via the Value Entry boxes for the
desired Manual scale settings. When adjusting the Min and Max
values, avoid a situation where large measurement fluctuations may
go beyond the maximum and minimum vertical settings. Off scale
readings are displayed as straight lines at the top or bottom of the
chart, as appropriate.

PowerScope The PowerScope window provides a graphical display of the laser's
temporal characteristics (Power Analysis function). The
PowerScope window can be turned ON or OFF by choosing the
PowerScope menu item from the View Menu, pressing the Ctrl+F2
keyboard button, or clicking the  button on the tool bar.

Normally when PowerScope is started, the gain is automatically
adjusted to provide the best vertical scale displayed on the graphics
portion of the screen. Alternatively, the user can deselect Autoscale
so that a specific value for the vertical scale can be chosen. This is
done by clicking on Vertical (up or down arrows). The location of
the zero on the vertical scale can be changed by using the Shift
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buttons (up and down arrows). The horizontal scale on the graphic
display can be modified and a Shift can be introduced. The sampling
frequency is displayed and automatically changed when the hori-
zontal scale is changed.

The numeric value of power is displayed in the Power Window. The
Power Peak, Peak to peak (mW) and Peak to peak (%) are part of the
Power Info screen.

Main Features and Advantages of the Power Analysis Function

1. Optical power stability and noise analysis in the time domain.

2. Optical power modulation depth.

3. Complete beam analysis in one integrated system, which elim-
inates the need for multiple setups.

Power Scope Buttons

Save: Click the Save button to save the current PowerScope data.
The Save functions automatically assigns a file name corresponding
the current date and time with a .psd or .xls file extension.

Setup: Click the Setup button to access all of the PowerScope Setup
parameters. The setup parameters allow the user to set the data view
file options to save data and colors.

The PowerScope function is a unique feature provided with the
BM-7 and BM-3* USB detector heads only and is not supported
in older BM-3 heads.

To get help on this window, press F1 on the keyboard when the
window is active. The Active window is the window in the window
area with the highlighted title bar.
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PowerScope Setup PowerScope Setup is selected from the Setup button in the
PowerScope window. The PowerScope Setup dialog contains three
tabs: Settings, File, and Colors.

Settings Tab

• View: Select the type of data view (digital or graphical mode).

File Tab

• Create File Name: Select Automatic or Manual for the name
creation of the PowerScope data file.

• File Type: Select Log or Excel. A log file is saved in a standard
text format. An Excel file is saved as an Excel Workbook.

• File Name: If you selected Manual mode in the Create File
Name field, click the Browse button to assign a file name and
path for the PowerScope data file.
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Colors Tab

• Colors: The Colors tab allows the user to specify background
and plot colors for the PowerScope window. A standard
Window color palette is available.

When you are satisfied with all of the selections utilizing each tab,
press OK to confirm the settings. Click Cancel at any time to exit the
PowerScope Setup screen and revert to the previous settings.

View Tool Bar View Tool Bar can be hidden, or shown, by selecting either Tool Bar
from the View Menu, or pressing the Shift + Ins keyboard buttons.

This option enables the user to toggle between the Show Tool Bar
option and the Hide Tool Bar option.

When the Tool Bar is selected (activated), there is an additional line
on top of the window containing Tools (picture shortcuts to some of
the most common used system functions), along with date and time
information.

When this option is not selected, the Tool Bar line disappears. In this
case, the user has to activate the various system functions from the
menu or keyboard shortcuts.

View Status Bar View Status Bar can be hidden, or shown, by selecting either Status
Bar from the View Menu, or pressing the Ctrl + Ins keyboard
buttons.

This option enables the user to toggle between the Show Status Bar
option and the Hide Status Bar option.
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Options Menu The Options menu allows the user to operate the saved measurement
data, perform Test an save images and snapshot files.

• Load Configuration File: This option allows the user to load
a certain configuration file containing all the system setup
parameters.

• Save Configuration File: This option allows the user to save
the current BeamMaster-USB software settings.

• Save Image as: This function is used to save the active
window or full screen as a *.BMP or *.JPG file.

• Save Snapshot: This function is used to save the laser beam
data information displayed to a file with a *.SNP extension.

• View Snapshot: This function is used to view the laser beam
data information saved to a file with a *.SNP extension.

• Save Data in Text File: This function is used to save the
profiles or projection data displayed to text file for analysis
with other programs.

• Start Test: This function is used to start and stop automatic
online Pass/Fail testing for user-selected parameters.

• Step: In this mode, the last measurement is displayed and the
window is frozen.

• Server Mode: This option is provided to enable a remote oper-
ation of the application program.

• User Data: This option enables the user to insert any string of
characters that will appear in the Log/Test files.
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• Close All Windows: When this item is selected, all open
windows are closed.

• Save Settings on Exit: This option allows the user to save the
current software settings in a default configuration file
($$$.INI).

A check mark in front of a menu item indicates that the function is
active.

A gray menu item means that the item is currently unavailable and
that additional conditions must be met for this item to be active. For
example, to start log, the appropriate log setup parameters must be
set.

Load 
Configuration File

Load Configuration File can be selected from the Options menu,

pressing the Ctrl + O keys, or by clicking the  button on the Tool

Bar.

This option allows the user to load a specific configuration file (files
with a .INI extension) containing all the system setup parameters.

Loading a Pre-saved Configuration File

1. Select Load Configuration File from the Options Menu, press
the Ctrl + O buttons, or click the shortcut button on the Tool
Bar. There is no need to change the file type because INI is the
default.

The BeamMaster-USB data files are located in the Data folder
in the BeamMaster-USB directory. The Beam-
Master-USB directory is located in Program Files by
default.

2. Click on the desired INI file from the file list on the left.

3. Click OK to load the file. The BeamMaster-USB software will
update all windows with the new configuration.

Automatic Configuration

The BeamMaster-USB software automatically saves the current
configuration each time it is closed. Enabling the Save Settings
option on Exit (from the Options menu) will cause the
BeamMaster -USB software to store the current configuration into
the default configuration file, ($$$.INI) upon exiting the software.
When the software is started, it will automatically load the $$$.INI
file.
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Save 
Configuration File

1. Select Save Configuration File from the Options menu. There
is no need to change the “File Type” because .ini is the default.
The BeamMaster-USB data files are located in the “Data”
folder in the BeamMaster-USB directory. The Beam-
Master-USB directory is located in “Program Files” by
default.

2. Type a filename for the configuration file in the box below the
word “File name.” The file saving process will automatically
attach the .ini file extension.

3. Click OK. The configuration file can now be loaded at any
time using the Load Configuration File command—see “Load
Configuration File” (p. 4-57).

Configuration File 
Contents

The following information is stored in the Configuration (INI) file.

• System serial number

• System wavelength setting

• System clip level setting

• Setting for averaging

• Setting for head tilt

• Setting for system beep

• Active windows size & position

• Setup parameters for each window

• Test setup parameters

Save Image as The Save Image as function is selected from the Options Menu.

This function is used to save the active window or full screen as a
*.BMP file or a *.JPG file.

Saving an Image File

1. Select Save Image as from the Options Menu.

2. Select Active Window or Full Screen option or, alternatively,
press the F11 key to start saving to the active window. A stan-
dard Windows file dialog is displayed.

3. Select BMP or JPG as the File Type.
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4. Select the desired file directory.

5. Type a filename for the image file in the box below the word
File name. The file saving process will automatically attach
the appropriate file extension.

6. Click OK.

Save Snapshot Save Snapshot is selected from the Options menu.

This function is used to save the laser beam data information
displayed to a file having the *.SNP extension. The data is saved as
a binary file and can be processed by this application program later.

Saving a Profile Snapshot

1. Select Save Snapshot  menu item from the Options menu. A
standard Windows file dialog is displayed. There is no need to
change the File Type because SNP is the default.

2. Select the desired storage directory.

3. Type a filename for the snapshot file in the box below the word
File name. There is no need to have the file name end in .SNP
as the program automatically saves the file with that extension.

4. Click OK.

View Snapshot View Snapshot is selected from the Options menu.

This function is used to view the laser beam data information saved
to a file having the *.SNP extension.

Viewing a Snapshot File

1. Select View Snapshot menu item from the Options menu. A
standard Windows file dialog is displayed.

2. Select a snapshot file.

3. Click Open. The snapshot file displays.

Closing a Snapshot File

To close a Snapshot file, select the View Snapshot menu item from
the Options menu. The system restores real-time measurement
displays. Alternatively, press the X sign at the right top corner of the
Windows screen application.
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Saving Data in Text 
File

1. Select the Save Data in Text File menu item from the Options
menu.

2. Select Profiles or Projection option. A standard Windows file
dialog is displayed. There is no need to change the File Type
because .TXT is the default.

3. Select the desired storage directory.

4. Type a filename. The .txt file extension will automatically be
attached during the saving process.

5. Click OK.

Importing Files into 
Excel

All BeamMaster-USB files are stored in ASCII file format for easy
printing, viewing, and analysis. Loading any of the data files directly
into Excel will activate the import wizard. A “fixed width” or “space
delineated” file format works best when using the import wizard.

Start Test Start Test is selected from the Options menu, or via the  button
on the Tool Bar.

This function is used to start and stop automatic online Pass/Fail
testing for user-selected parameters.

• Pause: The Pause button  stop testing temporarily. Press the
button again to continue.

• Print: The Print button prints the test results directly to the
default Windows printer.

• Save: The Save button saves the test results to a file name with
a .TXT file extension (for a text file) or a .XLS file extension
(for an Excel file). The data file will be located in the
BeamMaster-USB data folder 
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• Setup: The Setup button will display the configuration
window utilized to set the test parameters, as well as file name
options.

To close the Test window, select Stop Test under the Options Menu,

or click the  button on the Tool Bar.

Test Setup Test Setup is selected from the Test Window. This Setup window is
used to enter general information about the test and to activate any
of the nine available parameters. When configured for the first time
the Min and Max values will be based on the current detector head
limits.

• User Name, User Data: These fields are available to enter
information associated with the test.

• Measurements: Any one of the listed 9 parameters can be
activated by placing the mouse cursor at the option box and
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clicking the LEFT mouse button once. Each active parameter
requires a minimum and maximum level setting.

• Create File Name: One of the following two options can be
activated for saving a test file:

• Automatic - Automatically assigns a file name corre-
sponding the current date and time with a .TXT or .XLS
file extension. Each press on the Save button creates a
new file, with the above naming procedure.

• Manual - Get a file name from File Name frame.

• File Type: One of the following two options can be used to
save test data:

• .TXT - for a text file

• .XLS - for an Excel file

•  File Name: This frame is enabled if the Manual option is
selected in the Create File Name frame 

• When all the desired parameters are set, click the OK button to
confirm the selection, click Cancel to restore the previous
settings, or press the System button to reach the System Setup.

Step Mode Access the Step mode by selecting Step from the Options window,

pressing the F9 key, or by clicking the  button on the Tool Bar.

In this mode, the last measurement is displayed and the window is
frozen.
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The Step tool bar button will be disabled unless the system is in Step
mode. To enter Step mode: Select System Setup  from the System
menu and toggle from  Mode.

To take the next measurement, do one of the following: 

• Click the  button on the Tool Bar

• Press the F9 key

• Select the Step menu item from the Options Menu

Server Mode Server Mode is selected from the Options menu, or via the 
button on the Tool Bar.

This option is provided to enable a remote operation of the applica-
tion program.

1. Select Server Mode menu item from Options Menu, or press

the button on the Tool Bar. A blinking icon will appear at

the Tool Bar, adjacent to the Time field.

2. Rest the mouse cursor at the blinking icon—this will display
the Server Host Address (for identification of the client
computer via TCP/IP protocol).

3. Using the same system CD disk, install the software on the
remote computer and start the program. The following
message will display:

System Error #XX : BeamMaster-USB system cannot be
started. Please contact your Provider. 

4. Press OK. The following message will display:

Would you like to initiate a remote Client application?

5. Press Yes.

6. Input the Host Address name of the Server computer and then
press OK.

At this point, a hardware testing routine will be performed.
From this stage and on, the remote client computer will
be running the same software and all measurements and
analysis functions will be performed identically to the
main computer which hosts the hardware.
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User Data User Data is selected from the Options menu.

User Data enables the user to insert any information required during
the measurement session. The User Data string is limited to 60 char-
acters.

After inserting the user data information and pressing the OK button,
the information inserted will automatically be displayed in the Title
Bar, just right of the system name.

Close All Windows Close All Windows can be initiated by either selecting this option
from the Options Menu or by pressing the Ctrl + W keys. 

When this item is selected, all open windows are closed.

Save Settings on 
Exit

Save Settings on Exit is selected from the Options Menu.

This option allows the user to save the current software settings in a
default configuration file ($$$.INI). When the software is started, it
will automatically load this saved configuration file.

A check mark in front of the Save Settings on Exit menu item indi-
cates that this function is active. The default setting is enabled.

System Menu The System menu allows the user to operate with system data.

• System Setup: System Setup allows BeamMaster-USB to be
configured to suit a particular set of test needs.

• Add Detector Head: This function allows the user to
configure an additional detector head.

The available keyboard shortcuts are displayed on the right side of
the menu. These shortcuts may be activated from the Main Window
by pressing the corresponding keyboard combinations.
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A check mark in front of a menu item indicates that the function is
active.

A gray menu item indicates that the item is currently unavailable.
For example, to start log it has to first be setup.

System Setup System Setup can be accessed via the System button in each opera-
tional window, or from the System Menu. The system Setup can also
be accessed by clicking the current Wavelength display in the status
bar. System Setup allows BeamMaster-USB to be configured to suit
a particular set of test needs.

Wavelength This setting is accessed from the System Setup dialog.

The wavelength value is utilized to calculate the current power
reading. Wavelength should be set to match the laser source. Beam-
Master-USB detectors have response curves that are dependent on
the wavelength. These response curves have been corrected within
the calibration file. Therefore, it is important to enter the correct
wavelength to obtain a correct power measurement.

Possible Values for Wavelengths

• 190 to 1100 nm for the silicon-UV version

• 800 to 1800 nm for the InGaAs version
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Clip Level This setting is accessed from the System Setup dialog.

The System Clip Level sets the clip level where most of the system
calculations are performed. These calculations include: Beam
Width, Gaussian Fit, and Elliptical measurements.

A clip level defines the percentage of the peak intensity profile at
which beam is measured. For example, a clip level of 50% indicates
that the beam is to be measured at its full width at half maximum
(FWHM), whereas a clip level of 13.5% measures the beam at a
point that is 13.5% of the peak of the profile. The 13.5% level corre-
sponds to the 1/e2 point of a Gaussian profile.

Select a value for the System Clip Level from the Value Entry Box.
The selected value will be displayed on the Status Bar.

Average The Average setting is accessed from the System Setup dialog. The
System Setup dialog can be accessed from the System Menu or by
clicking on the wavelength field in the Status Bar.

The Average function provides a successive averaging feature which
smoothes the Position, Profile, and Power displays of noisy or
unstable lasers. The average can be set to integer values between
1 and 20. A value of 1 corresponds to no averaging.

For example, if a value of 10 is chosen, ten successive measurements
are averaged and the result is displayed. When an eleventh measure-
ment is taken, the first measurement value is dropped and the second
through the eleventh are averaged.

The selected value determines the number of successive measure-
ments that will be averaged. A successive averaging technique
results in an update rate that is not affected.

Select an Average value from the Value Entry Box. The selected
value is displayed on the Status Bar.
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Head Tilt This setting is accessed from the System Setup dialog.

The Head Tilt option is utilized to input the actual orientation of the
head. This option will orient the on-screen view to match physical
reality. This option is utilized in a situation where the measured
width of a laser beam does not coincide exactly with either the V or
W axes defined by the BeamMaster-USB.

The Head Tilt feature is especially important when analyzing ellip-
tical beams. When the knife-edges are not properly oriented with
respect to the major and minor axes of the ellipse, the width
measurements along V and W will not reflect the true maximum and
minimum widths of the beam. If the beam cannot be rotated, it is
necessary to physically rotate the measuring head about the optical
axis of the laser beam.

Select an Head Tilt value via the Value Entry Box. The selected
value is displayed on the Status Bar.

Mode This setting is accessed from the System Setup dialog.

The Mode function is used to switch between a real-time mode of
display (Run), and a manually-activated mode (Step).

• In Run mode the window display is updated continuously in
real-time.

• In Step mode the last measurement is displayed and the
window is frozen. A single new set of measurements will be
made only when a Step command is selected.

The Step function is selected by clicking the  Tool Bar
button  or by pressing the F9 key . A Step menu item is
also available in the Options menu. The Step function
allows a detailed examination to be made on each profile
captured.

Toggle between these two options using the radio button—see
“Radio Button” (p. 3-8). The mode selected is displayed on the
Status Bar.
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Beep This setting is accessed from the System Setup dialog. The System
Setup dialog can be accessed from the System menu or by clicking
on the current wavelength value in the Status Bar.

The Beep Option box controls whether BeamMaster-USB will
produce the default system beep whenever an error occurs. For
example, when Beep is turned ON and the laser source is OFF, the
Low Power error will be displayed while the system beeps.

Select Beep using the Option box.

Color Scheme The color scheme tab enables the user to set the background and
foreground colors for all windows. Select the desired color from the
standard Windows color pallet. Custom colors are also available
with the appropriate video card and Windows color setting.
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The Position, Profile W, Profile V, Power, Projection, Plot, and Chart
windows allow selection of the background and foreground colors.

Selecting a Color Scheme

1. Click Color scheme on the Color tab of System Setup.
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2. Select the color scheme from the drop-down menu.

3. Press and hold the Preview button to view the selected colors
without accepting the settings and exiting the dialog.

4. Press the Set button to change the color scheme for all
windows.

Creating a New Color Scheme

1. Click Color scheme on the Color tab of System Setup.

2. Select “User defined” from the droop-down menu.

3. Place the mouse over the desired color box and click the LEFT
mouse button once.

4. Press the Save button to save a new color scheme based on the
selected color labels.
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5. Press the Set button to change the color scheme for all
windows.

Add Detector 
Head

The Add Detector Head function is selected from the System Menu.

This function allows the user to configure an additional detector
head.

Loading
4 - 71



BeamMaster-USB User Manual
This option enables identifying the detector head serial number
which is currently being connected to the system, or selecting any
required detector serial number from the calibration file list. Press
the Ok button to confirm setting, or press the Cancel button to abort.

Adding Calibration Files

Copy all calibration files from the CD disk (or floppy disk or Flash
disk) provided with the sensor head to the current BeamMaster-USB
working directory.

Upon activating this option, a data entry box is displayed. Input the
detector Serial Number, then appropriate drive where the disk was
inserted. Press Copy to confirm the selection, Cancel to abandon.

During the copying operation, a message box is displayed,
presenting the name of the file being copied to BeamMaster-USB
working directory and the amount of data copied.

Windows Menu The Windows menu allows the user to graphically arrange the open
windows.

• Cascade: This command will attempt to arrange all open
windows on top of each other, but slightly null for each of
selection.
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• Tile Vertical: This command will attempt to tile the open
windows horizontally along the top of the window area. It
works well with two open windows. When more windows are
active they will overlap. The overlap results when the window
size cannot be reduced to a level to fit the available area.

• Tile Horizontal: This command will attempt to tile the open
windows vertically along the left edge of the window area. It
works well with two open windows. When more windows are
active they will overlap. The overlap results when the window
size cannot be reduced to a level to fit the available area.

• Arrange Icons: When a window is minimized it is reduced to
a icon representation and stacked along the bottom of the
window area. These icons can be moved around with the
mouse. To return them to a ordered group of icons along the
bottom of the window area, select this function. This is useful
if the icon has been covered up with another window. Higher
windows screen resolutions may help.

Help Menu When a Help subject is displayed, additional help can be displayed
by pressing the F1 key.

• Contents: This function allows the user to access Help infor-
mation on the active window.

• Search for Help On: This option will bring up a list of all the
topics in the Help system.

• Active Window: This option retrieves context-sensitive help
on the active window.

• Coherent on the Web: The link on the Website.

• About: The About screen provides the current software
version, detector head serial number, and copyrights.
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The list of keys or key combinations on the right side of the menu
indicate the corresponding keyboard shortcut for that feature. These
shortcuts may be activated from the Main window by pressing the
keyboard combination.

Contents The Contents function is selected from the Help Menu. 

This function allows the user to access Help information on the
current active window. 

To access the on-line BeamMaster-USB Manual, select the Contents
menu item form the Help Menu. The Contents topic are organized
into chapters. To find information on a desired topic, click on the
displayed chapter heading.

You can return to the Table of Contents by clicking Contents.

To find specific information fast, use the Search for Help On menu
item under the Help menu.

Search for Help On The Search for Help On function is selected from the Help Menu, or
alternatively, by pressing the Ctrl+F1 key. 

Additional help can be displayed on the current subject by pressing
the F1 key. This option will bring up a list of all the topics in the Help
system. Type the first few letters of the topic of interest. The search
engine will automatically select any topic that matches the entry. If
no entries match your topic, scroll through the list to a find a related
topic.

You can also click the Find tab. Windows will compile a cross-refer-
ence list of all the word used in the Help file. Using Find will often
pinpoint the exact topics of interest.

Active Window The Active Window function can be accessed by selecting it the

Help Menu, pressing the F1 key, or clicking the  button on the

Tool Bar.

The Active Window can be identified by a colored title bar back-
ground. A depressed tool bar button indicates the windows available
for selection. Activate a window by clicking on any part of the
window. To get context-sensitive help on the active window, click
the F1 key, select Active Window from the Help Menu or click the
Help button on the Tool Bar. This will bring up the help topic for the
current active Window.
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Coherent on the 
Web

The Coherent on the Web function is selected from the Help Menu.

The Website item in the Help Menu will start the default browser and
connect to http://www.coherent.com.

About The About box is selected from the Help Menu.

The About screen provides the current software name and version,
detector head, serial number, and copyright information. 

The Close button will clear the About information from the screen.
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Hardware
SECTION FIVE: HARDWARE

This section covers the following technical specifications:

• Dimensions and distances (p. 5-2)

• BM-3 InGaAs detector head (p. 5-3)

• BM-3 Silicon detector head (p. 5-4)

• BM-3 Silicon-UV detector head (p. 5-5)

• BM-3* InGaAs detector head (p. 5-6)

• BM-3* Silicon detector head (p. 5-7)

• BM-3* Silicon-UV detector head (p. 5-8)

• BM-7 InGaAs detector head (p. 5-9)

• BM-7 Silicon detector head (p. 5-10)

• BM-7 Silicon-UV detector head (p. 5-11)

• USB external box (p. 5-12)

All detector heads conform to applicable CE Mark standards.
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Dimensions and 
Distances

BM 3* - New revision of the BM-3 measuring head, starting from SN: 4000A.
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BM-3 InGaAs 
Detector Head

Figure 5-1.  BM-3 InGaAs Detector Head Dimensions

Table 5-1.  BM-3 InGaAs Detector Head Specifications

Parameter Description

Spectral Response 800 to 1800

Number of Knife-Edges 3

Sensor Input Aperture 5 mm circular (active area Ø3)

Dimensions 35.2 mm (W) x 105 mm (H) x 87.5 mm (L)

Weight 22 oz.

Minimum Detectable Power 10 µW

Maximum Power Power up to 5 mW

Relative Power Measurement 0.1 µW resolution

Power Measurement Accuracy ± 10%

Damage Threshold 1W/mm2 with total power less than 5 mW at sensor

Optical Dynamic Range 10 µW/cm2 to 10W/mm2 (no filter)

Beam Size Range (at 1/e2) 3 mm to 3 µm

Beam Width Resolution width < 100 µm: 0.1 µm
width >= 100 µm: 1.0 µm

Beam Position Resolution 1 µm

Beam Position Accuracy ± 15 µm

Distance to Image Plane See “Dimensions and Distances” (p. 5-2)

Maximum Update Rate 5 Hz—see “Speed Issues” (p. 6-6)

Cable 2.5 m long, attached to the head

Filters The InGaAs head does not use filters due to mechanical constraints.

Blade eccentricity for the BM-3 is ± 15 µm.
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BM-3 Silicon 
Detector Head

Figure 5-2.  BM-3 Silicon Detector Head Dimensions

Table 5-2.  BM-3 Silicon Detector Head Specifications

Parameter Description
Spectral Response 400 to 1100

Number of Knife-Edges 3

Sensor Input Aperture 5 mm circular

Dimensions 35.2 mm (W) x 105 mm (H) x 87.5 mm (L)

Weight 22 oz.

Minimum Detectable Power 10 µW

Maximum Power @ 633 nm No filter: Power up to 5 mW
NG4 filter: Power up to 50 mW
NG9 filter: Power up to 1W

Relative Power Measurement 0.1 µW resolution

Power Measurement Accuracy ± 5%

Damage Threshold 200W/mm2 with total power less than 5 mW at sensor

Optical Dynamic Range 10 µW/cm2 to 10W/mm2 (no filter)

Beam Size Range (at 1/e2) 5 mm to 3 µm

Beam Width Resolution width < 100 µm: 0.1 µm
width >= 100 µm: 1.0 µm

Beam Position Resolution 1 µm

Beam Position Accuracy ± 15 µm

Distance to Image Plane See “Dimensions and Distances” (p. 5-2)

Maximum Update Rate 5 Hz—see “Speed Issues” (p. 6-6)

Cable 2.5 m long, attached to the head

Filters NG4 and NG9. See filter files NG4.FLT and NG9.FLT for a text format transmis-
sion table.

Blade eccentricity for the BM-3 is ± 15 µm.
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BM-3 Silicon-UV 
Detector Head

Figure 5-3.  BM-3 Silicon-UV Detector Head Dimensions

Table 5-3.  BM-3 Silicon-UV Detector Head Specifications

Parameter Description
Spectral Response 190 to 1100

Number of Knife-Edges 3

Sensor Input Aperture 5 mm circular

Dimensions 35.2 mm (W) x 105 mm (H) x 87.5 mm (L)

Weight 22 oz.

Minimum Detectable Power 10 µW

Maximum Power @ 633 nm No filter: Power up to 5 mW
NG4 filter: Power up to 50 mW
NG9 filter: Power up to 1W

Relative Power Measurement 0.1 µW resolution

Detector Type UV-enhanced Si 10*10 mm

Damage Threshold 200W/mm2 with total power less than 5 mW at sensor

Optical Dynamic Range 10 µW/cm2 to 10W/mm2 (no filter)

Beam Size Range (at 1/e2) 5 mm to 3 µm

Beam Width Resolution width < 100 µm: 0.1 µm
width >= 100 µm: 1.0 µm

Beam Position Resolution 1 µm

Beam Position Accuracy ± 15 µm

Distance to Image Plane See “Dimensions and Distances” (p. 5-2)

Maximum Update Rate 5 Hz—see “Speed Issues” (p. 6-6)

Cable 2.5 m long, attached to the head

Filters NG4 and NG9 can be used for the 350 to 1100 nm range. See filter files NG4.FLT and 
NG9.FLT for a text format transmission table.

Blade eccentricity for the BM-3 is ± 15 µm.
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BM-3* InGaAs 
Detector Head

BM-3* - New revision of the BM-3 measuring head, starting from SN: 4000A

Figure 5-4.  BM-3* InGaAs Detector Head Dimensions

Table 5-4.  BM-3* InGaAs Detector Head Specifications

Parameter Description

Spectral Response 800 to 1800

Number of Knife-Edges 3

Sensor Input Aperture 5 mm circular (active area Ø3)

Dimensions 35.2 mm (W) x 105 mm (H) x 87.5 mm (L)

Weight 22 oz.

Minimum Detectable Power 10 µW

Maximum Power Power up to 5 mW

Relative Power Measurement 0.1 µW resolution

Power Measurement Accuracy ± 10%

Damage Threshold 1W/mm2 with total power less than 5 mW at sensor

Optical Dynamic Range 10 µW/cm2 to 10W/mm2 (no filter)

Beam Size Range (at 1/e2) 3 mm to 3 µm

Beam Width Resolution width < 100 µm: 0.1 µm
width >= 100 µm: 1.0 µm

Beam Position Resolution 1 µm

Beam Position Accuracy ± 15 µm

Distance to Image Plane See “Dimensions and Distances” (p. 5-2)

Maximum Update Rate 5 Hz—see “Speed Issues” (p. 6-6)

Cable 2.5 m long, attached to the head

Filters The InGaAs head does not use filters due to mechanical constraints.

Blade eccentricity for the BM-3 is ± 15 µm.
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BM-3* Silicon 
Detector Head

BM-3* - New revision of the BM-3 measuring head, starting from SN: 4000A

Figure 5-5.  BM-3* Silicon Detector Head Dimensions

Table 5-5.  BM-3* Silicon Detector Head Specifications

Parameter Description
Spectral Response 400 to 1100

Number of Knife-Edges 3

Sensor Input Aperture 5 mm circular

Dimensions 35.2 mm (W) x 105 mm (H) x 87.5 mm (L)

Weight 22 oz.

Minimum Detectable Power 10 µW

Maximum Power @ 633 nm No filter: Power up to 5 mW
NG4 filter: Power up to 50 mW
NG9 filter: Power up to 1W

Relative Power Measurement 0.1 µW resolution

Power Measurement Accuracy ± 5%

Damage Threshold 200W/mm2 with total power less than 5 mW at sensor

Optical Dynamic Range 10 µW/cm2 to 10W/mm2 (no filter)

Beam Size Range (at 1/e2) 5 mm to 3 µm

Beam Width Resolution width < 100 µm: 0.1 µm
width >= 100 µm: 1.0 µm

Beam Position Resolution 1 µm

Beam Position Accuracy ± 15 µm

Distance to Image Plane See “Dimensions and Distances” (p. 5-2)

Maximum Update Rate 5 Hz—see “Speed Issues” (p. 6-6)

Cable 2.5 m long, attached to the head

Filters NG4 and NG9. See filter files NG4.FLT and NG9.FLT for a text format transmission 
table.

Blade eccentricity for the BM-3 is ± 15 µm.
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BM-3* 
Silicon-UV 
Detector Head

BM-3* - New revision of the BM-3 measuring head, starting from SN: 4000A

Figure 5-6.  BM-3* Silicon-UV Detector Head Dimensions

Table 5-6.  BM-3* Silicon-UV Detector Head Specifications

Parameter Description
Spectral Response 190 to 1100

Number of Knife-Edges 3

Sensor Input Aperture 5 mm circular

Dimensions 35.2 mm (W) x 105 mm (H) x 87.5 mm (L)

Weight 22 oz.

Minimum Detectable Power 10 µW

Maximum Power @ 633 nm No filter: Power up to 5 mW
NG4 filter: Power up to 50 mW
NG9 filter: Power up to 1W

Relative Power Measurement 0.1 µW resolution

Detector Type UV-Enhanced Si 10*10 mm

Damage Threshold 200W/mm2 with total power less than 5 mW at sensor

Optical Dynamic Range 10 µW/cm2 to 10W/mm2 (no filter)

Beam Size Range (at 1/e2) 5 mm to 3 µm

Beam Width Resolution width < 100 µm: 0.1 µm
width >= 100 µm: 1.0 µm

Beam Position Resolution 1 µm

Beam Position Accuracy ± 15 µm

Distance to Image Plane See “Dimensions and Distances” (p. 5-2)

Maximum Update Rate 5 Hz—see “Speed Issues” (p. 6-6)

Cable 2.5 m long, attached to the head

Filters NG4 and NG9 can be used for the 400 to 1100 nm range. See filter files NG4.FLT 
and NG9.FLT for a text format transmission table.

Blade eccentricity for the BM-3 is ± 15 µm.
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BM-7 InGaAs 
Detector Head

Figure 5-7.  BM-7 InGaAs Detector Head Dimensions

Table 5-7.  BM-7 InGaAs Detector Head Specifications

Parameter Description

Spectral Response 800 to 1800, calibrated range: 800 to 1720 nm

Number of Knife-Edges 7

Sensor Input Aperture 9 mm square (active area Ø3)a

Dimensions 35.2 mm (W) x 105 mm (H) x 87 mm (L)

Weight 22 oz.

Minimum Detectable Power 10 µW

Relative Power Measurement 0.1 µW resolution

Maximum Power Power up to 5 mW (> 0.1 mm diam.)

Power Measurement Accuracy ± 10%

Damage Threshold 200W/mm2 with total power less than 5 mW at sensor

Optical Dynamic Range 10 µW/cm2 to 10W/mm2 (no filter)

Beam Size Range (1/e2) 3 mm to 10 µm

Beam Width Resolution width < 100 µm: 0.1 µm
width >= 100 µm: 1.0 µm

Beam Position Resolution 1 µm

Beam Position Accuracy ± 15 µm

Distance to Image Plane See “Dimensions and Distances” (p. 5-2)

Maximum Update Rate 5 Hz—see “Speed Issues” (p. 6-6)

Cable 2.5 m long, attached to the head

Filters The InGaAs head does not use filters due to mechanical constraints.

Blade eccentricity for the BM-7 is ± 30 µm.

a. Optional: An InGaAs 5 mm diameter detector is also available (model BM7-InGaAs-5)
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BM-7 Silicon 
Detector Head

Figure 5-8.  BM-7 Silicon Detector Head Dimensions

Table 5-8.  BM-7 Silicon Detector Head Specifications

Parameter Description

Spectral Response 400 to 1100

Number of Knife-Edges 7

Sensor Input Aperture 9 mm square

Dimensions 35.2 mm (W) x 105 mm (H) x 87 mm (L)

Weight 22 oz.

Minimum Detectable Power 10 µW

Relative Power Measurement 0.1 µW resolution

Maximum Power @ 633 nm No filter: Power up to 5 mW (> 0.1 mm diam.)
NG4 filter: Power up to 50 mW
NG9 filter: Power up to 1W

Power Measurement Accuracy ± 5%

Damage Threshold 200W/mm2 with total power less than 5 mW at sensor

Optical Dynamic Range 10 µW/cm2 to 10W/mm2 (no filter)

Beam Size Range (at 1/e2) 9 mm to 15 µm

Beam Width Resolution width < 100 µm:0.1 µm
width >= 100 µm:1.0 µm

Beam Position Resolution 1 µm

Beam Position Accuracy ± 15 µm

Distance to Image Plane See “Dimensions and Distances” (p. 5-2)

Maximum Update Rate 5 Hz—see “Speed Issues” (p. 6-6)

Cable 2.5 m long, attached to the head

Filters NG4 and NG9. See filter files NG4.FLT and NG9.FLT for a text format transmis-
sion table.

Blade eccentricity for the BM-7 is ± 30 µm.
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BM-7 Silicon-UV 
Detector Head

Figure 5-9.  BM-7 Silicon-UV Detector Head Dimensions

Table 5-9.  BM-7 Silicon-UV Detector Head Specifications

Parameter Description

Spectral Response 190 to 1100

Number of Knife-Edges 7

Sensor Input Aperture 9 mm square

Dimensions 35.2 mm (W) x 105 mm (H) x 87 mm (L)

Weight 22 oz.

Minimum Detectable Power 10 µW

Relative Power Measurement 0.1 µW resolution

Maximum Power @ 633 nm No filter: Power up to 5 mW (> 0.1 mm diam.)
NG4 filter: Power up to 50 mW
NG9 filter: Power up to 1W

Detector Type UV-enhanced Si 10*10 mm

Damage Threshold 200W/mm2 with total power less than 5 mW at sensor

Optical Dynamic Range 10 µW/cm2 to 10W/mm2 (no filter)

Beam Size Range (at 1/e2) 9 mm to 15 µm

Beam Width Resolution width < 100 µm:0.1 µm
width >= 100 µm:1.0 µm

Beam Position Resolution 1 µm

Beam Position Accuracy ± 15 µm

Distance to Image Plane See “Dimensions and Distances” (p. 5-2)

Maximum Update Rate 5 Hz—see “Speed Issues” (p. 6-6)

Cable 2.5 m long, attached to the head

Filters NG4 and NG9 filters can be used for 350 to 1100 nm. See filter files NG4.FLT and 
NG9.FLT for a text format transmission table.

Blade eccentricity for the BM-7 is ± 30 µm.
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USB External Box The BeamMaster-USB uses the USB external box to digitize and
store the information from the detector head.

There are two LEDs on the external box front panel:

• GREEN illuminates when installation of the external box is
successful.

• RED illuminates when there is an alert (possible installation
issue).

The Power connector and On/Off switch are future options.

There is 15-pin connector on the back of the external box. This
connector is connected to the detector head via the detector cable.

Figure 5-10.  USB External Box (front view)

Table 5-10.  USB External Box Specifications

Parameter Description

Bus USB 2.0

Cable USB 2.0, 0.9m length

Weight 0.37 kg

Dimensions 165 mm x 120 mm x 30 mm

Power Input Requirements (typical) +5V @ 0.1A (supplied via USB cable)

Ambient Operating Temperature 10 to 35°C

A/D Converter 20 MHz sample rate at 12 bits

CE Mark Conforms to all applicable CE mark standards

LEDs

Figure 5-11.  USB External Box (rear view)
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SECTION SIX: CALCULATIONS SUMMARY

In this section:

• Accuracy (this page)

• Relative total power (p. 6-2)

• Beam width (p. 6-3)

• Beam centroid location (p. 6-3)

• Gaussian fit (p. 6-4)

• Ellipticity (p. 6-6)

• Speed issues (p. 6-6)

Accuracy The following topics provide information on how to optimize the
BeamMaster-USB to achieve the highest measurement accuracy.

The accuracy of all calculations is affected by beam peak inten-
sity, centering, size, and background noise.

To insure optimum measurement accuracy, the following items must
be properly maintained:

• The beam spot size should not exceed the recommended
minimum or maximum beam diameter for the detector head
being used (refer to the detector head specifications in the
“Section Five: Hardware,” section, which starts on p. 5-1).

• The beam position should be centered in the sensor area, with
no beam area overlapping the edge of the input aperture on the
detector head.

• The beam incidence should be normal to the face of the
detector head.

• The background noise in the beam image can affect the calcu-
lated results. Ensure that all sources of background noise have
been eliminated if possible (“Background Noise,” is discussed,
below).

• The successive Averaging feature can also be used to smooth
noise and beam variations.
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Background Noise Several sources of background noise can contribute to the overall
noise level in the system. This topic discusses the most common
noise sources.

Electronic Noise

Electronic noise can be a concern with instruments being used in
association with lasers. The BeamMaster-USB has passed CE Mark
tests indicating that it is resistant to most EMI radiation. Still,
Intense High frequency sources can induce noise into the cables and
detector head electronics. Avoid grounding the detector head and
BeamMaster-USB chassis with the laser or its power supply in a
manner that could make them susceptible to ground loops. Severe
damage to the detector head and electronics may result. It is also
recommended that the BeamMaster-USB system power supply be
surge protected and isolated from the laser power source.

Background Light

Background light noise seen by the detector head is another problem
that should be closely monitored. This noise comes from sunlight,
room lights, flash lamps, and instrumentation lights. One of the
filters can be used to reduce background light. The Power Offset
feature can be used to remove the ambient light from the power
reading.

Thermal Noise

Thermal noise can also affect the long-term stability of the Beam-
Master-USB. Drift in detector head voltage and A/D converter
circuits due to large changes in room and instrumentation tempera-
tures can contribute to background noise. The system should be
allowed to reach a stable operating temperature each time it is used.
This can take as long as 20 minutes.

Relative Total 
Power

The rotating drum in the detector head contains multiple knife-edge
apertures. As an aperture passes between the laser beam and the
stationary power sensor, there is a period of time where the entire
beam is allowed to reach the sensor. At this point the Beam-
Master-USB can measure the total power of the beam.

The power reading is adjusted, based on the system wavelength
setting and the wavelength response curve for the detector, and the
transmission of the current filter.

For details on minimum detectable power, measurement resolution,
maximum power, and damage threshold limits, see the appropriate
detector head specifications.
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Power Accuracy

The silicon detectors are calibrated with and without the filters for
power accuracy at 633. The InGaAs detector is calibrated for power
accuracy at 1320 nm. The system is designed for ± 10% accuracy at
the specified wavelengths; therefore, the BeamMaster-USB does not
provide absolute power accuracy at this time. Consider the Power
reading to be Relative.

If absolute power accuracy is desired, the BeamMaster-USB power
reading can be hand-calibrated using a power meter. If the Beam-
Master-USB reading needs adjusting, a filter file can be created that
provides the necessary correction at the given wavelength.

Beam Width The Beam Width is measured at a clip level.

A clip level defines the percentage of the peak intensity profile at
which beam is measured. For example, a clip level of 50% indi-
cates that the beam is to be measured at its full width at half
maximum (FWHM). A clip level of 13.5% measures the beam at
a point that is 13.5% of the peak of the profile. The 13.5% level
corresponds to the 1/e2 point of a Gaussian profile.

The BeamMaster-USB obtains the beam profile information, as
outlined under “Theory of Operation” (p. 1-3).

The maximum value in the profile is found and set to 100%. The
Profile is searched to find the points most closely matching the clip
level. The distance between the specified clip level points is the
beam width.

If no point matches the clip level, linear interpolation is used to find
the edge.

If the profile crosses the clip level more than two times, the system
picks the edges closest to the beam profile center of gravity (typi-
cally the main lobe).

If the edge of the beam is cut off because it intersects the edge of the
aperture, the profile will appear truncated on that edge.

Beam Centroid 
Location

Before each blade there is a “start-of-scan” signal acting as an indi-
cator for the beam location on the detector surface. Each system is
calibrated relative to the start-of-scan. The system calculates the
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time from start-of-scan to the “center of gravity” of the profile. The
“center of gravity” is determined for the W axis with the following
calculation:

Where:

w = location along W axis
p(w) = intensity at location w on W axis
I = total intensity of W profile
W = center position of W axis

Simple axis translation is then used to present the data in X-Y coor-
dinates.

The Affect of Background Ambient Light

Profiles are obtained by performing a derivation on the digitized
power curve. Ambient light is suppressed since it is constant over
the detector surface, resulting in a derivative of zero. However, if a
low power, large-area beam is examined, it is important to suppress
background illumination as much as possible.

Gaussian Fit The Gaussian Fit is a least-squares fit of a Gaussian equation to the
cross-section beam profiles. The correlation coefficient is the
normalized sum of the residuals of the fit.

The following equation is used to determine the Gaussian Fit:

Where:

I = the intensity of a pixel at location x
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In performing a least squares fit to this equation, the following terms
are derived:

V = the maximum intensity of the fitted Gaussian 
curve (Peak intensity)

C = the center of the Gaussian fit peak (Centroid)
s = the radius of the Gaussian fit curve at the 1 /e2 

intensity level (Diameter)

Gaussian Fit 
Diameter

The Gaussian Diameter is the width of the Gaussian fit at the clip
level specified.

Gaussian 
Correlation 
Coefficient

Given a theoretical Gaussian curve (G) and a set of data points from
a beam profile (P), the Gaussian correlation coefficient is calculated
as follows:

Where each data set is composed of points for j = 0, 1, 2, ... N. The
correlation coefficient is derived, from the following steps.

1. S, the Integration of the squared differences between the two
curves is found:

2. The deformation at each point from the average, Dj, is then
determined:
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3. The fit coefficient, C, is a percentage, defined with the
following formula:

Ellipticity Elliptical measurements are calculated utilizing data from three
blades. The actual calculation is in accordance with standard
formulas for ellipse calculations utilizing three chords.

1. The major and minor axes of the fit ellipse are calculated by
determining the distance from the centroid to the ellipse.

2. Orientation (Theta) measures the orientation of the major axes
of the fit. Theta is measured from the positive X-axis and
varies between +90º and -90º.

Speed Issues The motor speed limits the maximum update rate to 5 Hz. The soft-
ware can acquire data at 5 Hz by starting a Data Collection Log file
when all graphic screens are closed.

When several windows are opened, the system may slow down,
especially when using the 3D feature. High performance computers
can display the data faster. The update rate of a particular computer
is influenced by a variety of factors: CPU speed, computer RAM, the
video card, video ram, screen resolution, screen color depth, and the
specific operating system being used.
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SECTION SEVEN: TROUBLESHOOTING

This section lists common problems and probable solutions for the
following error types:

• System errors (this page)

• Analysis errors (p. 7-2)

System Errors System errors are displayed on the right-hand side of the tool bar.
They indicate a problem with the hardware or detector head. When
these errors are displayed, all results are removed from the window.

Low power 

This message means that insufficient light is available on the
detector. This error will occur if less than 10 µW of energy is
detected. Verify that the laser light is reaching the sensor. If it
appears that the message is incorrect, treat it as a Hardware Failure
message (explained, next).

Hardware operation failed 

A Hardware Operation Failed message indicates that a problem
exists with the USB external box. One of the following solutions
could resolve this problem.

1. The USB external box settings do not match the software setup
parameters—refer to “Installing the USB External Box”
(p. 2-5).

2. The detector head is not connected, or the cable is loose—see
“Connecting the Detector” (p. 2-3).

3. There is no measurement taken during 2 to 4 drum rotations.
This might be due to some problem in the head or the USB
external box electronics.

Power adjusting 

This message is normal and can occur when:

1. There is a sudden change in laser power.

2. The user has just completed setting the hardware or system
setup parameters.
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Laser power exceed limit 

This message indicates the detector is collecting an excessive
amount of light. Check the input power level with a power meter to
ensure the device is being used within the recommended operating
limits. With small beams this error can occur below the published
power limit—for a list of published limits, refer to “Section Five:
Hardware” (p. 5-1). If it appears that the message is incorrect, treat
it as a hardware failure—refer to “Hardware operation failed”
(p. 7-1).

Frequency adjusting 

This message is normal and can occur when:

1. There is a sudden change in laser position or size.

2. The user has just completed setting the hardware or system
setup parameters.

Check detector head 

This message displays in one of the following cases:

1. Whenever the measuring head is being connected to the mani-
fold box and the calibration files in use do not match the head.
To correct this error, change the head S/N—refer to “Add
Detector Head” (p. 4-71).

2. When the measuring head is malfunctioning. If this happens,
contact Coherent—refer to “Obtaining Service” (p. 10-2).

Analysis Errors Analysis errors are associated with calculations and data collection.

Small beam display on the Position window

The Position window does not automatically zoom for small beams.
To enable Position Zoom mode, select the Position Setup button and
enable the zoom feature. The zoom function will scale the position
display relative to the current beam diameter.

Power is not correct

• Check that the correct wavelength is entered into the System
Setup dialog.

• Make sure the filter installed in the detector head matches the
filter selected in the software.

• Ensure that the sensor is not saturated—for a list of specifica-
tions—refer to “Section Five: Hardware” (p. 5-1).
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• If using a small spot, check the power density levels—see
“Selecting a Filter” (p. 2-4). The relative power reading should
be ± 10% of the actual power level. If an absolute power
reading is required, set up a custom filter file— refer to “Create
Filter File” (p. 4-2). A custom filter file allows the user to enter
a power correction factor. This factor will be multiplied by the
transmission value at the specified wavelength.

Calculation Issues

Refer to “Accuracy” (p. 6-1).
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Head Accessories and Drawings
SECTION EIGHT: HEAD ACCESSORIES AND 
DRAWINGS

In this section:

• BeamMaster-USB rotation mount (this page)

• Fiber adapter (p. 8-2)

• C-mount adapter ring (p. 8-2)

BeamMaster-USB 
Rotation Mount

Part number: 1038024

The rotation mount is designed to attach to the 8-32 holes on the
BeamMaster-USB head and provide precise rotation of the head
about the optical axis.

It is sometimes necessary to rotate the BeamMaster-USB head about
the optical axis. Each head is provided with three 8-32 threaded
mounting holes on its rear plate for this purpose.

Figure 8-1.  BeamMaster-USB Rotation Mount
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Fiber Adapter

Part number: 33-7154-000

The fiber adapter is provided with an FC connector and is designed
to just fit onto the aperture of the BeamMaster-USB detector head.
The fiber adapter can firmly hold an optical fiber with FC connector
end quite close to the detector knife-edge plane for measurement of
its output beam profile.

C-Mount 
Adapter Ring

Part number: 33-7147-000

The C-Mount Adapter Ring is designed to attach to the face of the
BeamMaster-USB detector head. This adapter will accommodate
optical devices utilizing a 1" x 32 thread pattern.

Figure 8-2.  Fiber Adapter

Figure 8-3.  C-Mount Adapter Ring
8 - 2



Windows Control Library
SECTION NINE: WINDOWS CONTROL LIBRARY

Overview The BeamCtrlLib.dll Windows Control Library is a software
package required when writing an application program for the
BeamMaster-USB system.

The BeamCtrlLib.dll Windows Control Library contains
easy-to-operate functions and properties that enable measuring
beam parameters and help you create your own application under
Windows XP, Windows Vista, or Windows 7. The BeamCtrlLib.dll
Windows Control Library was written using Microsoft .Net C#.

Description of Files

Windows Control Library is a software tool for managing the
BeamMaster-USB system under the Windows operating system. For
proper operation, the Windows Control Library requires the
following files:

• BeamCtrlLib.dll: Windows Control Library

• Beam USB Control.dll: Additional Windows Control Library

• BMxxxx.up: Detector calibration file supplied with the
measuring system, where “BMxxxx” refers to the detector
number

In the sub-directory of examples on the Installation CD, there is an
example of using BeamCtrlLib Windows Control Library with the
C# programming language.

Description of the BeamCtrlLib Windows Control Library
Functions

• GetCorrelation: Function returns the correlation coefficient
of the Gaussian

• GetGaussianWidth: Function returns the width of the
Gaussian at a certain clip level

• GetProfileWidth: Function returns the width of the profile at
a certain clip level

• ProfileData: Function returns the measured profile as an array
of points

• ProfileUnit: Function returns the distance between points in
microns in the measured profile

• Start: Function to initialize and start the measurement system

• Stop: Function of stopping the measuring system
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Description of the BeamCtrlLib Windows Control Library
Properties

• Average: Sets and returns the average of the measuring system

• CurrentStatus: Returns the current status of the state
measuring system

• EllipseError: Returns the state of reconstruction of the ellipse
of the measured laser beam

• EllipseLevel: Sets and returns the current ellipse level of the
measured laser beam

• EllipseMajor: Returns the value of the major ellipse axis of
the measured laser beam

• EllipseMinor: Returns the value of the minor ellipse axis of
the measured laser beam

• EllipseOrientation: Returns the angle between the major axis
of the ellipse and the X-axis of the measured laser beam

• Position: Returns the current position of the measured laser
beam

• Power: Returns the current power of the measured laser beam

• ProjectionData: Returns a matrix of two-dimensional recon-
struction of the laser beam

• ProjectionUnit: Returns the distance (in microns) between
points in the matrix of two-dimensional reconstruction of the
laser beam

• Wavelength: Sets and returns the wavelength (in nanometers)
of the measured laser beam

Description of Events BeamCtrlLib Windows Control Library

• OnErrorMessage: Event notifying change of the status of the
measuring system

• OnUpdateData: Event notifying the receipt of new data from
the measuring system

Description of BeamCtrlLib Windows Control Library
Enumerations

ErrorStatus: Specifies options for the state of the measuring system

Description of Enumerations BeamCtrlLib Windows Control
Library

• ErrorStatus: Specifies options for the state of the measuring
system
9 - 2



Windows Control Library
GetCorrelation Function returns the Gaussian correlation coefficient.

Namespace: BeamCtrlLib

Assembly: BeamCtrlLib

Syntax

Visual Basic (Declaration) 

Public Function GetCorrelation ( _

 uiNumPrf As UInt16 _ 

) As Double

Visual Basic (Usage) 

Dim numProfile As UInt16

Dim corelation As Double

corelation = GetCorrelation(numProfile)

C# 

public double GetCorrelation(UInt16 uiNumPrf)

Parameters

uiNumPrf

The number of measured profile.

Remarks

This method is a member of the class BeamCtrlLib. To be able to
apply to this method and obtain the results of measurements, there is
a need to first create an object of class BeamCtrlLib and run it with
Start function.

The uiNumPrf  parameter corresponds to the serial number of the
knife in the measuring system, starting from 0.

Return Value

This function returns the Gaussian correlation coefficient.
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GetGaussian-
Width

Function returns (in microns) the width of the Gaussian at a certain
clip level.

Namespace: BeamCtrlLib

Assembly: BeamCtrlLib

Syntax

Visual Basic (Declaration) 

Public Function GetGaussianWidth( _

 uiNumPrf As UInt16 _

 fLevel As Single _

) As Double

Visual Basic (Usage) 

Dim numProfile As UInt16

Dim width As Double

Dim level As Single

width = GetGaussianWidth(numProfile, level)

C# 

public double GetGaussianWidth(UInt16 uiNumPrf, float
fLevel)

Parameters

uiNumPrf

    The number of measured profile.

fLevel

    The clip level as a percentage of the height profile.

Remarks

This method is a member of the class BeamCtrlLib. To be able to
apply to this method and obtain the results of measurements, there is
a need to first create an object of class BeamCtrlLib and run it with
Start function.

The uiNumPrf  parameter corresponds to the serial number of the
knife in the measuring system, starting from 0.

The fLevel parameter indicating the percentage clip level at which
the beam width profile is being measured. The values of this param-
eter may be in the range of 0.0, for the lowest point of the measured
profile and up to the maximum value of 100.0, highest point of the
measured profile.

Return Value

This function returns (in microns) the width of the Gaussian at a
certain clip level.
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GetProfileWidth Function returns (in microns) the width of the profile at a certain
clip level.

Namespace: BeamCtrlLib

Assembly: BeamCtrlLib

Syntax

Visual Basic (Declaration) 

Public Function GetProfileWidth( _

 uiNumPrf As UInt16 _

 fLevel As Single _

) As Double

Visual Basic (Usage) 

Dim numProfile As UInt16

Dim width As Double

Dim level As Single

width = GetProfileWidth(numProfile, level)

C# 

public double GetProfileWidth(UInt16 uiNumPrf, float
fLevel)

Parameters

uiNumPrf

    The number of measured profile.

fLevel

    The clip level as a percentage of the height profile.

Remarks

This method is a member of the class BeamCtrlLib. To be able to
apply to this method and obtain the results of measurements, there is
a need to first create an object of class BeamCtrlLib and run it with
the Start function.

The uiNumPrf  parameter corresponds to the serial number of the
knife in the measuring system starting from 0.

The fLevel parameter indicates the percentage clip level at which the
beam width profile is measured. The values of this parameter may
be in the range of 0.0, for the lowest point of the measured profile,
and up to the maximum value of to 100.0, highest point of the
measured profile.

Return Value

This function returns (in microns) the width of the profile at a certain
clip level.
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ProfileData Function returns the measured profile as an array of points.

Namespace: BeamCtrlLib

Assembly: BeamCtrlLib

Syntax

Visual Basic (Declaration) 

Public Function ProfileData( _

 uiNumPrf As UInt16 _

) As Single()

Visual Basic (Usage) 

Dim numProfile As UInt16

Dim profile() As Single

profile = ProfileData(numProfile)

C# 

public Single[] ProfileData(UInt16 uiNumPrf)

Parameters

uiNumPrf

    The number of measured profile.

Remarks

This method is a member of the class BeamCtrlLib. In order to be
able to apply to this method and obtain the results of measurements,
there is a need to first create an object of class BeamCtrlLib and run
it with the Start function.

The uiNumPrf  parameter corresponds to the serial number of the
knife in the measuring system starting from 0.

Each array element represents a percentage of the maximum height
profile and presented in a range from 0 to 100. 

To obtain the actual distance in microns between the points in the
resulting profile use the ProfileUnit function.

Return Value

This function returns the measured profile as an array of points.
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ProfileUnit Function returns the distance between points (in microns) in the
measured profile.

Namespace: BeamCtrlLib

Assembly: BeamCtrlLib

Syntax

Visual Basic (Declaration) 

Public Function ProfileUnit( _

 uiNumPrf As UInt16 _

) As Double

Visual Basic (Usage) 

Dim numProfile As UInt16

Dim profileunit As Double

profileunit = ProfileUnit(numProfile)

C# 

public double ProfileUnit(UInt16 uiNumPrf, )

Parameters

uiNumPrf

    The number of measured profile.

Remarks

This method is a member of the class BeamCtrlLib. In order to be
able to apply to this method and obtain the results of measurements,
there is a need to first create an object of class BeamCtrlLib and run
it with function Start.

The uiNumPrf  parameter corresponds to the serial number of the
knife in the measuring system starting from 0.

Return Value

This function returns the real distance (in microns) between points
in the array profile obtained function ProfileData.
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Start Function to initialize and start the measurement system.

Namespace: BeamCtrlLib

Assembly: BeamCtrlLib

Syntax

Visual Basic (Declaration) 

Public Function Start( _

 strFileName As String_

) As BeamCtrlLib.BeamCtrlLib.ErrorStatus

Visual Basic (Usage) 

Dim numProfile As String

Dim errStatus As BeamCtrlLib.BeamCtrlLib.ErrorStatus

errStatus = Start(numProfile)

C# 

public BeamCtrlLib.BeamCtrlLib.ErrorStatus
Start(String strFileName)

Parameters

strFileName

    The path in which the file resides BMxxxx.up.

Remarks

This method starts the measuring system and makes it automatic
configuration of the necessary mode for measuring data. For the
termination of the work and stop the measuring device, use the Stop
function.

BAxxxx.up file is a calibration file of measuring detector and comes
with the measuring system. Where “BMxxxx” = the detector
number. 

Return Value

This function returns one of the states described in ErrorStatus.
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Stop Function of stopping the measuring system.

Namespace: BeamCtrlLib

Assembly: BeamCtrlLib

Syntax

Visual Basic (Declaration) 

Public Sub Stop()

C# 

public void Stop()

Remarks

This function terminates the measuring process and turns off the
measuring system which was started by the Start function.

Average Property sets and returns the average value of the measuring system.

Namespace: BeamCtrlLib

Assembly: BeamCtrlLib

Syntax

Visual Basic (Declaration) 

Public Property Average() As UInt16

C# 

public UInt16 Average

Return Value

This property returns the average value of the measured laser beam.
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CurrentStatus Property returns the current status of the measuring system.

Namespace: BeamCtrlLib

Assembly: BeamCtrlLib

Syntax

Visual Basic (Declaration) 

Public Property CurrentStatus() As BeamCtrlLib.BeamC-
trlLib.ErrorStatus

C# 

public BeamCtrlLib.BeamCtrlLib.ErrorStatus Current-
Status

Remarks

This property returns the current state of the measuring system,
which is the state of one of the ErrorStatus.

Return Value

This function returns one of the states described in ErrorStatus.

EllipseError Property returns the status of the ellipse reconstruction.

Namespace: BeamCtrlLib

Assembly: BeamCtrlLib

Syntax

Visual Basic (Declaration) 

Public Property EllipseError() As Boolean

C# 

public Boolean EllipseError

Return Value

This property returns the status of the measured laser beam ellipse
reconstruction.
9 - 10



Windows Control Library
EllipseLevel Property sets and returns the current ellipse level of the measured
laser beam.

Namespace: BeamCtrlLib

Assembly: BeamCtrlLib

Syntax

Visual Basic (Declaration) 

Public Property EllipseLevel() As Single

C# 

public Single EllipseLevel

Return Value

This property sets and returns the current ellipse level of the
measured laser beam.

Ellipse level value indicates the percentage clip level of the beam
profile, where ellipse data calculated. The values of this property
may be in the range of 0.0, for the lowest point of the measured
profile, and up to the maximum value of to 100.0, highest point of
the measured profile.

EllipseMajor Property returns the value of the major ellipse axis.

Namespace: BeamCtrlLib

Assembly: BeamCtrlLib

Syntax

Visual Basic (Declaration) 

Public Property EllipseMajor() As Single

C# 

public Single EllipseMajor

Return Value

This property returns the value of the major ellipse axis of the
measured laser beam.

If the ellipse axes ratio exceeds limit, then the property returns a
“None” value. Use EllipseError property to make sure that the
reconstruction of the ellipse is correct.
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EllipseMinor Property returns the value of the minor ellipse axis.

Namespace: BeamCtrlLib

Assembly: BeamCtrlLib

Syntax

Visual Basic (Declaration) 

Public Property EllipseMinor() As Single

C# 

public Single EllipseMinor

Return Value

This property returns the value of the minor ellipse axis of the
measured laser beam.

If the ellipse axes ratio exceeds limit, then the property returns a
“None” value. Use EllipseError property to make sure that the
reconstruction of the ellipse is correct.

EllipseOrientation Property returns the angle orientation of the ellipse.

Namespace: BeamCtrlLib

Assembly: BeamCtrlLib

Syntax

Visual Basic (Declaration) 

Public Property EllipseOrientation() As Int16

C# 

public Int16 EllipseOrientation

Return Value

This property returns the angle (in degrees) between the major axis
of the measured laser beam ellipse and the X-axis.
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Position Property returns the current position of the measured laser beam.

Namespace: BeamCtrlLib

Assembly: BeamCtrlLib

Syntax

Visual Basic (Declaration) 

Public Property Position() As PointF

C# 

public PointF Position

Return Value

This property returns (in microns) the current position of the
measured laser beam.

Power Property returns the current power measured laser beam.

Namespace: BeamCtrlLib

Assembly: BeamCtrlLib

Syntax

Visual Basic (Declaration) 

Public Property Power() As Single

C# 

public Single Power

Return Value

This property returns (in mW) the current power of the measured
laser beam.
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ProjectionData Property returns a matrix of two-dimensional reconstruction of the
laser beam.

Namespace: BeamCtrlLib

Assembly: BeamCtrlLib

Syntax

Visual Basic (Declaration) 

Public Property ProjectionData() As UInt16(,)

C# 

public UInt16[][] ProjectionData

Return Value

This property returns a matrix of two-dimensional reconstruction of
the laser beam.

To obtain the actual distance in microns between the points in the
resulting matrix, use the ProjectionUnit function.

ProjectionUnit Property returns the distance (in microns) between points in the
matrix of two-dimensional reconstruction of the laser beam.

Namespace: BeamCtrlLib

Assembly: BeamCtrlLib

Syntax

Visual Basic (Declaration) 

Public Property ProjectionUnit() As Double

C# 

public double ProjectionUnit

Return Value

This property returns the distance (in microns) between points in the
matrix of two-dimensional reconstruction of the laser beam,
obtained by the ProjectionData function.
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Wavelength Property sets and returns the wavelength (in nanometers) of the
measured laser beam.

Namespace: BeamCtrlLib

Assembly: BeamCtrlLib

Syntax

Visual Basic (Declaration) 

Public Property Wavelength() As Double

C# 

public double Wavelength

Return Value

This property returns the wavelength (in nanometers) of the
measured laser beam.

OnErrorMessage Event notifying a change of status of the measuring system.

Namespace: BeamCtrlLib

Assembly: BeamCtrlLib

Syntax

Visual Basic (Declaration) 

Public Event OnErrorMessage As ErrorMessage

C# 

public event ErrorMessage OnErrorMessage

OnUpdateData Event notifying the receipt of new data from the measuring system.

Namespace: BeamCtrlLib

Assembly: BeamCtrlLib

Syntax

Visual Basic (Declaration) 

Public Event OnUpdateData As UpdateData

C# 

public event UpdateData OnUpdateData
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ErrorStatus Specifies options for the state of the measuring system.

Namespace: BeamCtrlLib 

Assembly: BeamCtrlLib 

Syntax 

Visual Basic (Declaration) 

Public Enumerator ErrorStatus

C# 

public enum ErrorStatus

Members

Table 9-1.  Error Status Table

Member Name Description

BA_OK The measuring system is functioning properly.

BA_INMEASURE Optional (Not used)

BA_MEASURED Optional (Not used)

BA_INMOVE Optional (Not used)

BA_MOVEEND Optional (Not used)

BA_POWERADJUSTING The measuring system is able to configure power.

BA_ADJUSTING The measuring system is able to set the frequency.

BA_HARDFAILURE Measuring system not functioning correctly.

BA_WRONGPARAMETERS Optional (Not used)

BA_LOWMEMORY Optional (Not used)

BA_TOOHIGHPOWER Power of the laser beam more than the permissible measuring system. 

BA_TOOLOWPOWER The laser beam is less than the permissible measuring system.

BA_DARKPOWER The measuring system is able to measure dark power.

BA_PROFILELOST Optional (Not used)

BA_NOTOPENED Optional (Not used)

BA_NOTIMER Optional (Not used) 

BA_WRONGMODE Optional (Not used)

BA_SETUPNOTFOUND Setup file from the function Start can't be opened.

BA_SETUPWRONG Setup file is not a valid.

BA_NOTMEASURED Optional (Not used)

BA_TOOMANYPROFILES Optional (Not used)

BA_IRQERROR Optional (Not used)

BA_NOTOPENEDCOEFF Optional (Not used)
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Warranty and Service
SECTION TEN: WARRANTY AND SERVICE

In this section:

• Warranty (this page)

• Obtaining service (p. 10-2)

• Product shipping instructions (p. 10-3)

Warranty Coherent, Inc. makes no expressed or implied warranties that func-
tions and features of the BeamMaster-USB will meet the purchaser's
requirements for automated testing and beam diagnostics, or any
other application, or that the program operations will be uninter-
rupted or error- free. The foregoing warranties are in lieu of all other
warranties, expressed or implied, including, but not limited to, the
implied warranties of merchantability and fitness for a particular
purpose. Coherent does warrant that the hardware be free of defects
in materials and workmanship under normal use for a period of one
year from the date of delivery to the customer and evidenced by a
copy of the invoice.

In no event will Coherent, Inc. be liable for any damages, including
any lost profits, lost savings or other incidental or consequential
damages arising out of the use or inability to use the Beam-
Master-USB, even if Coherent has been advised of the possibility of
such damages, or for any claim by any other party. The risk in the
use of the BeamMaster-USB lies entirely with the purchaser.

Any unauthorized duplication and/or dissemination of Coherent's
program material or associated support documentation, is prohibited
by law.
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Obtaining 
Service

In order to obtain service under this warranty, Customer must notify
the Company of the defect before the expiration of the warranty
period and make suitable arrangements for the performance of
service. The Company shall, in its sole discretion, determine
whether to perform warranty service at the Customer's facility, at the
Company's facility or at an authorized repair station.

If Customer is directed by the Company to ship the product to the
Company or a repair station, Customer shall package the product (to
protect from damage during shipping) and ship it to the address
specified by the Company, shipping prepaid. The customer shall pay
the cost of shipping the Product back to the Customer in conjunction
with annual recalibration and repair; the Company shall pay the cost
of shipping the Product back to the Customer in conjunction with
product failures within the first twelve months of time of sale or
between annual recalibrations.

A Returned Material Authorization number (RMA) assigned by the
Company must be included on the outside of all shipping packages
and containers. Items returned without an RMA number are subject
to return to the sender.

For the latest Customer Service information, refer to our website:
www.Coherent.com.

Detailed instructions on how to prepare a product for shipping are
shown under “Product Shipping Instructions” (p. 10-3).

Table 10-1.  Coherent Service Centers

Location Phone Fax E-Mail

USA 1.800.343.4912 503.454.5777 info_service@Coherent.com

Europe +49-6071-968-0 +49-6071-968-499 info_service@Coherent.com

International 503.454.5700 503.454.5777 info_service@Coherent.com
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Product 
Shipping 
Instructions

To prepare the product for shipping to Coherent:

1. Contact Coherent Customer Service—refer to Table 10-1,
“Coherent Service Centers,” on page 2 for contact informa-
tion.

2. Attach a tag to the product that includes the name and address
of the owner, the person to contact, the serial number, and the
RMA number you received from Coherent Customer Service.

3. Wrap the product with polyethylene sheeting or equivalent
material.

4. If the original packing material and carton are not available,
obtain a corrugated cardboard shipping carton with inside
dimensions that are at least 15 cm (6 in.) taller, wider, and
deeper than the product. The shipping carton must be
constructed of cardboard with a minimum of 170 kg (375 lb.)
test strength. Cushion the instrument in the shipping carton
with packing material or urethane foam on all sides between
the carton and the product. Allow 7.5 cm (3 in.) on all sides,
top, and bottom.

5. Seal the shipping carton with shipping tape or an industrial
stapler.

6. Ship the product to:

Coherent, Inc.
27650 SW 95th Ave.
Wilsonville, OR 97070
Attn: RMA # (add the RMA number you received from

Coherent Customer Service)
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